Putty Trick – 1. Save output to a file

To automatically save the output to a file while using Putty, you can change one setting of Putty to achieve this.
1. Start putty.exe.
2. Go to Session -> Logging.
3. Select “Printable output”
4. Choose the folder, where you want the file to be placed.
5. Append a file name like &H_&Y&M&D_&T.log to the path (host_YearMonthDay_time.log)
6. Save the profile as default settings.

Advertisements

Notes on Cisco QoS: Clearing the fog – Part 2. Quality issues

Quality of Service

QOS = Method of giving priority to some specific traffic as moving over the network.

The basic aim of QoS is to have a consistent and predictable performance on your network.

 

1 qos intro

General characteristics of today’s Converged Network:

  • Small voice packet compete with bursty data packets, many different applications are using network as services
  • Critical traffic must get priority over less critical traffic, without QoS, default behavior is First In First Out (FIFO)
  • Voice and video traffics are time-sensitive
  • Outages are not acceptable

 

Converged Network Quality issues:

  • Lack of Bandwidth
  • Packet Loss
  • Delay
  • Jitter

 

Bandwidth

2 Bandwidth Measure.png

  • Maximum available bandwidth is the slowest link on the traffic paths
  • On the same physical links (traffic paths), multiple flows compete for the same bandwidth, multiple applications sharing the same bandwidth
  • Lack of bandwidth causes performance degradation on network applications

 

 

Packet Loss

3 Tail Drop due to Queue Congestion

Packet loss due to Tail Drop: Queue only can so much packets and once it is full and more packets arrive at the tail end of the queue before the queue is emptied (due to link congestion etc.), the packets will be dropped, and this behavior is called ‘Tail Drop’. If the tail drop occurs to the time sensitive traffics such as voice and video, the effects are immediately felt by the users on the flow. If this happens to data traffic, it may interrupt file transfer and corrupt the file.

 

 

Delay

4 Types of Delay

  • Processing Delay – time taken by router to process packets from an input interface and put them into the output queue of output interface
  • Queuing Delay – time a packet resides in the output queue of a router
  • Serialization Delay – time taken to place bits on the wire
  • Propagation Delay – time taken for packets to cross links from one end to the other end

 

 

Jitter

5 Jitter

  • Packets from a source will reach a destination with different delay times
  • Congestion on the network will cause jitter
  • Congestion can occur at a router interface/Service Provider network if the circuits are not properly provisioned

 

CCNA Switching Lab 1-0: The set up

We will try to prepare a lab where we can configure and test different features of Cisco Routers and Switches. For the purpose of saving time and minimize our on-going efforts to set up each lab, two multi-purpose lab typologies will be configured, namely one for routing and another for switching. Once the lab is set up, it can be used in multiple scenarios and a lab can be configured on the fly to teach us the required technologies. This section is the switching part and will be titled ‘CCNA Switching Lab 1-x’, where x represents the lab number. In the same manner, the routing labs will be titled ‘CCNA Routing Lab 1-x’.

Lab prerequisite: You have followed my blog or other people’s blog, or watched YouTube and set up your GNS3 with IOU at some stage.

Step 1: As shown below, add four IOU routers and four IOU switches.

사용자 지정 2

 

Step 2: Connect all of your switches and routers

사용자 지정 1

 

Now you are ready to do some Switching labs. 🙂

사용자 지정 3

 

 

 

 

 

 

CCNA Routing Lab 1-0: The set up

We will try to prepare a lab where we can configure and test different features of Cisco Routers and Switches. For the purpose of saving time and minimize our on-going efforts to set up each lab, two multi-purpose lab typologies will be configured, namely one for routing and another for switching. Once the lab is set up, it can be used in multiple scenarios and a lab can be configured on the fly to teach us the required technologies. This section is the routing part and will be titled ‘Routing Lab 1-x’, where x represents the lab number. In the same manner, the switching labs will be titled ‘CCNA Switching Lab 1-x’.

Lab prerequisite: You have followed my blog or other people’s blog, or watched YouTube and set up your GNS3 with IOU at some stage.

I have drawn a lab topology  we are trying to configure and mimic:

사용자 지정 8

Step 1: As shown below, drop four IOU routers, two IOU L2 switches and one GNS3 native GNS3 Frame Relay Switch.

활성화 윈도우 4

Step 2: Add DLCIs in FR1 to prepare for Frame Relay Switch ready for connection.사용자 지정 3

Step 3: Connect all devices as shown below. and now you are ready to start your first Routing lab.

활성화 윈도우 1

 

 

 

 

 

CCNA Data Center 640-911 DCICN – Note 18, IPv6 Introduction

This is my first blog in 2016, I have been on holiday mode as I have been on one the longest annual leave in my life. Hope you understand the family commitment when you and your kids are on summer holiday (here in Sydney, Dec/Jan/Feb is blazing summer).

 

IPv6, the history and does it really matter to you or anyone?

The simple answer is YES, then why? The single biggest driver behind the development and introduction of IPv6 is  a long prediction of lack of usable IPv4 IP addresses since the explosion of World Wide Web (www) in 1995. The www development goes back to 1991 and then the introduction of grandfather web browser, Mosaic was first introduced in 1993. By year 1995, one third of IPv4 addresses were consumed, by year 2000, half of all IPv4 addresses were use.

As reviewed in previous notes, IPv4 consists of 32 bit address structure and theoretically that should give us 2 to the power of 32 IP addresses, that is 4294967296 IP addresses or roughly, 4.3 billion IP addresses . But not all IP addresses are usable such as the reserved IP addresses for private network use as well as the Class E addresses reserved for development and testing purposes. In other words, only around 2.5 billion IP addresses are true usable addresses. If you just check out our world’s population today ( http://www.worldometers.info/world-population/, China = 1.407 billion and India = 1.2912 billion people,), just looking at top two countries’ population figures, you can feel the IPv4 address shortage on your skin. The trend is that the world’s network has been doubling in size every year for the past 15 years. (https://en.wikipedia.org/wiki/IPv4_address_exhaustion)

With the advancement of new technologies comes the rapid deletion of available IPv4 IP addresses. Anything that’s related to mobile communications and entertainment as well as all other areas seems to be needing more and more IP addresses for everyday use. In the past, it was expected that all the IPv4 addresses would be depleted by 2011 but it is 2016 and we are still using IPv4 address without much thought, all thanks to the counter measures put into place to slow down the IPv4 IP address deletion. e.g.) The fine art of sub-netting, a practical use of DHCP and IP Natting.

 

 Quick note on history of IPv6:

1990 – IETF had predicted that all class B IPv4 IP addresses will be deleted by 1994
1991 Nov – IETF formed  ROAD (ROuting and ADress) Group in Santa Fe, US.
1995 – IPNG (IP Next Generation) Workgroup had written and submitted ‘RFC 1883’, this RFC has become the foundation of current IPv6.
1996 – 6Bone was introduced. 6Bone was a test-bed for IPv6 vulnerabilities connecting 57 countries across 1100 sites.
1999 – IPv6 Forum was launched to standardize the use of IPv6
2006 Jul 06 – 6Bone was decommissioned after 10 years of testing.
Current – Majority of IP products are manufactured with IPv6 capabilities and compatibility. IPv6 is slowly phasing out IPv4 around the world.

Source: https://en.wikipedia.org/wiki/IPv6

 

Quick note on 10 Advantages (Characteristics) of IPv6:
1. Larger IP address space than IPv4, 32 bits based IPv4 vs 128 bits based IPv6
2. Better end-to-end connectivity than IPv4
– peer-to-peer application connections such as games, video conferencing, file sharing and VoIP
– No need to use NAT as the shortage of addresses is thing of IPv4
3. Plug-n-Play feature of IPv6
– plug-and-play auto-configuration, e.g.) DHCPv6
4. Simplified Header structures leading to faster routing
5. Better security features
– use of IPSec (a built-in feature)
6. Improved QoS features
7. Improved Multicast and Anycast abilities
8. Better mobility features
9. Ease of administration over IPv4
10. IPv6 follows the key design principles of IPv4

Source: http://www.ipv6.com/articles/general/Top-10-Features-that-make-IPv6-greater-than-IPv4.htm

In the next section, we will look at some characteristics of IPv6 and then in the final section of IPv6, I will demonstrate IPv6 in a simple lab. Happy blogging, reading and all the best with your learning and career in 2016.

CUBE High Availability (HA) Using HSRP Configuration with port-channel twist

Starting with Cisco Gen2 router platforms, CUBE can provide the HSRP (Hot Standby Routing Protocol). That is you need two CUBE routers to confgure this setup. HSRP basically works on Active and Standby mode between two routers by monitoring both the inside and outside interfaces, if Active side goes down, then the Standby device becomes active and takes over the responsibilities of the Active router.

In CUBE HSRP Active/Standby pair scenario, the two CUBE routers keep exchange communications over the same virtual IP address. This setup will support media preservation over an HSRP switchover of SIP to SIP calls, but not the call signaling. Call signaling preservation is supported from IOS 15.2.3T.

Requirements:
1. Two identical ISR G2 routers with the correct IOS and license
*Cisco 2951 (x 2), IOS = c2951-universalk9-mz.SPA.154-3.M1, license =SL-29-UC-K9
2. Identiacal CUBE configuration
3. SIP-to-SIP call flows
Configuration:
1. Enable CUBE and CUBE Redundancy

Enable CUBE on CUBE01 and CUBE02:
voice service voip
mode border-element
allow-connections sip to sip

Enable CUBE redundancy and call checkpointing on both CUBES
voice service voip
redundancy
2. Enable HSRP

Enable router redundancy schemes on both routers, where:
scheme – redundancy state tracking scheme
standby – enable standby (HSRP) state tracking scheme
SB – the HSRP standby group name

redundancy inter-device
scheme standby SB

3. Configure HSRP Communication Transport

Configure the HSRP Inter-Device Communication Transport as follows:

Active Configuration:
ipc zone default <<< For Inter-Device Communication Protocol (IPC)
association 1 <<< Associates between two devices
no shutdown <<< Enables associations
protocol sctp <<< Stream Control Transmission Protocol (SCTP) for communication language
local-port 5000 <<< Defines the local SCTP port number
local-ip 10.10.24.14 <<< Defines the local router’s IP address
remote-port 5000 <<< Defines the remote SCTP port number
remote-ip 10.10.24.13 <<< Defines the remote router’s IP address

Standby Configuration:
ipc zone default
association 1
no shutdown
protocol sctp
local-port 5000
local-ip 10.10.24.13
remote-port 5000
remote-ip 10.10.24.14

4. Configure HSRP on the Interfaces

Configure the HSRP Inter-Device Communication Transport as follows:

Active Configuration

interface Port-channel1
description CUBE01 interface
ip address 10.10.10.11 255.255.255.0
standby delay minimum 30 reload 60 <<< Avoids race condition to establish contact between Active and Standby
standby version 2
standby 0 ip 10.10.10.1
standby 0 priority 50
standby 0 preempt
standby 0 name SB

interface GigabitEthernet0/0
no ip address
duplex full
speed 1000
channel-group 1

interface GigabitEthernet0/1
no ip address
duplex full
speed 1000
channel-group 1
Standby Configuration:

interface Port-channel1
description CUBE02 interface
ip address 10.10.10.12 255.255.255.0
standby delay minimum 30 reload 60
standby version 2
standby 0 ip 10.10.10.1
standby 0 priority 50
standby 0 preempt
standby 0 name SB

interface GigabitEthernet0/0
no ip address
duplex full
speed 1000
channel-group 1

interface GigabitEthernet0/1
no ip address
duplex full
speed 1000
channel-group 1
5. Configure the HSRP Timers

CUBE01(config-if)#standby 0 timers 2 msec 40 <<< configures failover and hold timers

CUBE02(config-if)#standby 0 timers 2 msec 40
6. Configure the Media Inactivity Timer

Enables the Active/Standby router pair to monitor and disconnect calls if no Real-Time Protocol (RTP) packets are received within a configurable time period. Default value is 28 seconds.

ip rtcp report interval 3000
gateway
media-inactivity-criteria all
timer receive-rtp 86400
timer receive-rtcp 5
7. Configure SIP Binding to HSRP Address

voice service voip
mode border-element license capacity 125
allow-connections sip to sip
redundancy
sip
bind control source-interface Port-channel1
bind media source-interface Port-channel1
asserted-id pai
asymmetric payload full
midcall-signaling passthru
privacy-policy passthru
sip-profiles 100
8. Reload the Routers

Active Router
CUBE01#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured

Standby Router
CUBE02#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
9. Point Attached Softswitches to the CUBE HSRP Virtual Address
On CUCM, this is configured on the SIP Trunk configuration under Device > Trunk.

SIP Trunk

 

**********************************************
Useful commands for verification and troubleshooting:
show redundancy inter-device
show redundancy states
show standby brief
show standby
show voice high-availability summary
show voice high-availability summary | include media
show voip rtp connection
show sip-ua status
show sip-ua statistics
debug standby

show process cpu history
show process cpu sorted

***********************************************

Notes on Cisco QoS: Clearing the fog – Part 1. Basic Introduction

  1. What is Quality of Service (QoS) ?

Analogy 1: QoS is a network tool which can be implemented to effectively transport more critical traffics over IP, which gives critical traffic a priority over less critical traffic.

Analogy 2: QoS is a method of giving a priority to some specific data traffic going across our network.

  • Give VoIP, Video traffic more priority than ftp file downloading traffic
  • Some critical Data such as Citrix etc.

 

  1. Converged Network Quality Issues

Today’s enterprise network Characteristics:

  • Benign small voice packet flows compete directly with busty data packet flows.
  • Voice load and voice application data (traffic) tolerate minimal variation in delay, packet loss or jitter. The voice quality degradation is immediately felt by the users.
  • Give critical traffic higher priority
  • Voice and video are real-time, hence time-sensitive
  • Outage/packet drops are not acceptable

 

Some issues from Converged Network:

  • Lack of bandwidth – If more traffic is pumped through the network more than the network can handle, there will be congestions and packet loss.
  • Packet Loss – If input queue pumps too much packets into an interface, output queue fills up, the packet is dropped.
  • Delay –
    • Processing delay – The time it takes for a router to take the packet from an input interface, examine it and put it into the output queue of the output interface
    • Queuing delay – The time a packet resides in the output queue of a router
    • Serialization delay – The time it takes to place the “bits on the wire”
    • Propagation delay – The time it takes for the packet to cross the link from one end to the other

 

  • Jitter –
    • Packets from the source will reach the destination with different delays
    • Jitter is generally caused by congestion in the IP network
    • The congestion can occur either at the router interfaces or in a provider or carrier network if the circuit has not been provisioned properly

 

To overcome these converged network quality issues, QoS tool(s) must be used based on each network.

 

Some Cisco recommended QoS tool types and their characteristics:

A. Best effort

– Out of box, if you do not configure your devices, it is using best effort

– Business network with no QoS policies

– Infrastructure does not support QoS

– FIFO

 

B. Integrated Services (IntServ)

– Aims to reserve bandwidth along a specific path in the network

– Guarantees end-to-end bandwidth for mission-critical applications such as VoIP and Citrix

– End-hosts signal their QoS requirements to the network (Signalled QoS model)

– Every communication stream needs to request resources from the network.

– Edge routers use Resource Reservation Protocol (RSVP) to signal and reserve bandwidth

 

Some disadvantages of IntServ:

– Every device along the network must be fully RSVP aware and have ability to process QoS

– Reservations in each devices along the path need to be periodically refreshed, adds traffic and overhead along the network

– “Soft-states” or bandwidth reservation increase memory and CPU requirements on devices along the path

– Adds complexity to the network which makes network infrastructure difficult to maintain

 

C. Differentiated Service (DiffServ)

– Designed to overcome the limitations of Best-Effort and IntServe model, while maintaining the ability to provide an almost guaranteed QoS

– Routers and switches are configured to service multiple classes of traffic with different priorities. Bandwidth, delay and prioritization are configured on a hop-to-hop basis along the network infrastructure, making diffServ cost-effective and scalable

– For DiffServ QoS to work, network traffic must be divided into classes that are based on the company’s requirements

– Network devices identify traffic as it passes through them and enforce the configured policies, making sure that each class/service is served as instructed

 

Reference:

http://docwiki.cisco.com/wiki/Quality_of_Service_Networking

http://searchunifiedcommunications.techtarget.com/tip/DiffServ-QoS-model-works-wonders-for-VoIP-networks