CCNA Security 210-260 (Santos & Stuppi): Ch01 Questions

I have been away from study as well as blogging for sometime due to my on-going health issues. This year alone, I’ve had three operations and have been off the tangent on my study. Actually, two but the last one was a spin-off of the second. The first was in May, embarrassing to say this but the operation was for hemorrhoidectomy and colonoscopy, it brought me down for about 3 weeks. Then 3 weeks ago, I’ve had a Tonsillectomy, I was so glad that I was finally saying good bye to my beloved 40 year old tonsillitis. Post operation, I was almost over the hill, then on the 14th day, a scab came off the operated part and started bleeding crazy. Last Sunday, I went into Emergency and after almost bleeding to death for 8 hours, the ENT specicialist decided to operate on me again under full anesthetics. I was out for another week and looking forward to going back to work tomorrow. Sadly, I felt the pain up the bumb as well as in the mouth this year. Hopefully, I can keep my promise to completed the CCNA Security 210-260 before the year end. ;).

For anyone who is also struggling with their study, keep your forcus and keep going until you see the end of the tunnel. Yes, there are many tunnels to crosss in our industry, if you stop, you might get run over by the traffic behind you, so keep moving. 🙂

To help the exam prep and also make some go to points, I will simply refer the questions from the books. Yes, I did purchased a hard copy to study for this exam, the videos are also also available from safaribooks.com (Santos & Stuppi videos). Older Barker version is available off torrent sites as form of cbtnugget videos. Love watching Keith Barker’s cbtnuggets, he is a true  legend!

1. Which security term refers to a person, property, or data of value to a company?
a. Risk
b. Asset
c. Threat prevention
d. Mitigation technique
B

2. Which asset characteristic refers to risk that results from a threat and lack of a countermeasure?
a. High availability
b. Liability
c. Threat prevention
d. Vulnerability
D

3. Which three items are the primary network security objectives for a company?
a. Revenue generation
b. Confidentiality
c. Integrity
d. Availability
B C D

4. Which data classification label is usually not found in a government organisation?
a. Unclassified
b. Classified but not important
c. Sensitive but unclassified
d. For official use only e. Secret
B
5. Which of the following represents a physical control?
a. Change control policy
b. Background checks
c. Electronic lock
d. Access lists
C

6. What is the primary motivation for most attacks against networks today?
a. Political
b. Financial
c. Theological
d. Curiosity
B

7. Which type of an attack involves lying about the source address of a frame or packet?
a. Man-in-the-middle attack
b. Denial-of-service attack
c. Reconnaissance attack
d. Spoofing attack
D

8. Which two approaches to security provide the most secure results on day one?
a. Role based
b. Defense in depth
c. Authentication
d. Least privilege
B D

9. Which of the following might you find in a network that is based on a defense-in-depth security implementation? (Choose all that apply.)
a. Firewall
b. IPS
c. Access lists
d. Current patches on servers
A B C D

10. In relation to production networks, which of the following are viable options when dealing with risk? (Choose all that apply.)
a. Ignore it
b. Transfer it
c. Mitigate it
d. Remove it
B C D

Advertisements

Chasing Packets in GNS3 & Production Environment, Part 2: IOS Embedded Packet Capture & tee off to a TFTF server

aaa2

IOS Embedded Packet Capture Configuration in a nutshell:

r1#monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

r1#monitor capture point ip cef E0_0 e0/0 both

r1#monitor capture point associate E0_0 PAKCETBUFFER

r1#monitor capture point start E0_0

 

Generate some traffic: example showing ICMP traffic generation

aaa9

Generate some RTP traffic: example showing use of Cisco IP communicator in this lab

aaa11.png

 

r1#monitor capture point stop E0_0

r1#monitor capture buffer PAKCETBUFFER export tftp://172.168.10.10/mycapture.pcap

 

***You must specify the name of the file, otherwise the teeing off to TFTP server will not work!!!

 

aaa8

 

Example of ICMP traffic packet capture:

aaa10.png

 

Example of RTP traffic packet capture.

aaa7

 

 

=======================================================================

Actual configuration:

r1#monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

 

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 0

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Inactive

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

 

r1#mon cap point ip cef E0_0 e0/0 both

*Apr  5 07:30:22.526: %BUFCAP-6-CREATE: Capture Point E0_0 created.

 

r1#show mon cap point all

Status Information for Capture Point E0_0

IPv4 CEF

Switch Path: IPv4 CEF            , Capture Buffer: None

Status : Inactive

 

Configuration:

monitor capture point ip cef E0_0 Ethernet0/0.100 both

 

r1#mon cap point associate E0_0 PAKCETBUFFER

 

r1#show mon cap point all

Status Information for Capture Point E0_0

IPv4 CEF

Switch Path: IPv4 CEF            , Capture Buffer: PAKCETBUFFER

Status : Inactive

 

Configuration:

monitor capture point ip cef E0_0 Ethernet0/0.100 both

 

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 0

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Inactive

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

 

 

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 0

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 3

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 4

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 657

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#mon cap point stop E0_0

r1#mon cap point stop E0_0

*Apr  5 07:34:11.582: %BUFCAP-6-DISABLE: Capture Point E0_0 disabled.

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 657

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Inactive

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

 

 

r1#show monitor capture buffer PAKCETBUFFER dump

07:33:16.228 UTC Apr 5 2016 : IPv4 LES CEF    : Et0/0.100 None

 

F4E2C230: AABBCC00 0100000C 2978156D 81000064  *;L…..)x.m…d

F4E2C240: 08004560 0034EE83 40007F06 1959C0A8  ..E`.4n.@….Y@(

F4E2C250: 640B8EC8 400B0570 07D079AA FEBF61F3  d..H@..p.Py*~?as

F4E2C260: 050A5018 FAC0BFD0 00000400 00001100  ..P.z@?P……..

F4E2C270: 00000000 000000                      …….

… Content omitted for brevity

 

 

r1#monitor capture buffer PAKCETBUFFER export ?

disk0:  Location to dump buffer

disk1:  Location to dump buffer

ftp:    Location to dump buffer

http:   Location to dump buffer

https:  Location to dump buffer

pram:   Location to dump buffer

rcp:    Location to dump buffer

scp:    Location to dump buffer

snmp:   Location to dump buffer

tftp:   Location to dump buffer

unix:   Location to dump buffer

 

r1#monitor capture buffer PAKCETBUFFER export tftp://172.168.10.10/mycapture.pcap

!

***You must specify the name of the file, otherwise the teeing off to TFTP server will not work!!!

 

Notes on Cisco QoS: Clearing the fog – Part 4. Modular QoS Lab

Lab topology:

Module QoS 2

How this lab can be configured in GNS3 on a single PC.

  • SW1 and SW2 is the local GNS3 switches, merely serving as a connector between PC1 and HTTP Server respectively. These dummy switches must be used while connecting virtual machines to GNS3 devices.

Module QoS 1

Step 1: Configure R1 and R2 to allow communication between the networks.

R1 base configuration:

hostname R1

interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 1.0.0.0
network 192.168.30.0
auto-summary

==============================================

R2 base configuration:

hostname R2

interface FastEthernet0/0
ip address 192.168.40.254 255.255.255.0
duplex auto
speed auto

router eigrp 1
network 1.0.0.0
network 192.168.40.0
auto-summary

==============================================

Step 2: Configure R1 with Access List, class-map and policy-map

access-list 200 permit icmp host 192.168.30.30 host 192.168.40.40 echo
access-list 200 permit icmp host 192.168.30.30 host 192.168.40.40 echo-reply
access-list 100 permit tcp any any eq www

class-map match-all WEB_TRAFFIC
match access-group 100
class-map match-all ICMP_TRAFFIC
match access-group 200

policy-map MODULAR
class ICMP_TRAFFIC
bandwidth 256
class WEB_TRAFFIC
bandwidth 128
class class-default

Step 3: Apply policy map to output queue of Serial 0/0

!Apply Service-policy to output interface s0/0

interface Serial0/0
ip address 1.1.1.1 255.255.255.0
clock rate 2000000
 service-policy output MODULAR

==============================================

Step 4: Run quick check on the configuration

R1#show class-map
Class Map match-all WEB_TRAFFIC (id 1)
Match access-group  100

Class Map match-any class-default (id 0)
Match any

Class Map match-all ICMP_TRAFFIC (id 2)
Match access-group  200

R1#show policy-map
Policy Map CCIE
Class ICMP_TR
Bandwidth 128 (kbps) Max Threshold 64 (packets)
Class WEB_TR
Bandwidth 64 (kbps) Max Threshold 64 (packets)
Class class-default

==============================================

Before any ping or http traffic is sent across the WAN link

R1#show policy-map interface s0/0
Serial0/0

Service-policy output: MODULAR

Class-map: ICMP_TRAFFIC (match-all)
    0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 112
Queueing
Output Queue: Conversation 265
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: WEB_TRAFFIC (match-all)
      0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 120
Queueing
Output Queue: Conversation 266
Bandwidth 64 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
697 packets, 46091 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

==============================================

Step 5: Generate ICMP traffic by pining the server from the client PC

To generate ICMP traffic, from the client PC (192.168.30.30) ping http server at 192.168.40.40.
ICMP pinging

‘show policy-map interface s0/0’ after 8 ping messages have been sent from 192.168.30.30 (client) to 192.168.40.40 (Server)

R1#show policy-map interface s0/0
Serial0/0

Service-policy output: MODULAR

Class-map: ICMP_TRAFFIC (match-all)
8 packets, 512 bytes <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 112
Queueing
Output Queue: Conversation 265
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: WEB_TRAFFIC (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 120
Queueing
Output Queue: Conversation 266
Bandwidth 64 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
766 packets, 50456 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

==============================================

Step 6: Access web page of http server from the client PC

To generate some http traffic, access http://192.168.40.40/ from the client PC to HTTP Server.
Access IIS

==============================================

show policy-map interface serial0/0 after generating http traffic

R1#show policy-map interface s0/0
Serial0/0

Service-policy output: MODULAR

Class-map: ICMP_TRAFFIC (match-all)
    12 packets, 768 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 112
Queueing
Output Queue: Conversation 265
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: WEB_TRAFFIC (match-all)
13 packets, 2539 bytes <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 120
Queueing
Output Queue: Conversation 266
Bandwidth 64 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
878 packets, 57842 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

 

==============================================

R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Serial0/0
D       1.0.0.0/8 is a summary, 00:59:46, Null0
C    192.168.30.0/24 is directly connected, FastEthernet0/0
D    192.168.40.0/24 [90/2195456] via 1.1.1.2, 00:59:41, Serial0/0

 

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Serial0/0
D       1.0.0.0/8 is a summary, 00:04:16, Null0
D    192.168.30.0/24 [90/2195456] via 1.1.1.1, 00:04:11, Serial0/0
C    192.168.40.0/24 is directly connected, FastEthernet0/0

 

All this lab was done on a laptop, go easy on the environment. 🙂

On a single PC

Notes on Cisco QoS: Clearing the fog – Part 2. Quality issues

Quality of Service

QOS = Method of giving priority to some specific traffic as moving over the network.

The basic aim of QoS is to have a consistent and predictable performance on your network.

 

1 qos intro

General characteristics of today’s Converged Network:

  • Small voice packet compete with bursty data packets, many different applications are using network as services
  • Critical traffic must get priority over less critical traffic, without QoS, default behavior is First In First Out (FIFO)
  • Voice and video traffics are time-sensitive
  • Outages are not acceptable

 

Converged Network Quality issues:

  • Lack of Bandwidth
  • Packet Loss
  • Delay
  • Jitter

 

Bandwidth

2 Bandwidth Measure.png

  • Maximum available bandwidth is the slowest link on the traffic paths
  • On the same physical links (traffic paths), multiple flows compete for the same bandwidth, multiple applications sharing the same bandwidth
  • Lack of bandwidth causes performance degradation on network applications

 

 

Packet Loss

3 Tail Drop due to Queue Congestion

Packet loss due to Tail Drop: Queue only can so much packets and once it is full and more packets arrive at the tail end of the queue before the queue is emptied (due to link congestion etc.), the packets will be dropped, and this behavior is called ‘Tail Drop’. If the tail drop occurs to the time sensitive traffics such as voice and video, the effects are immediately felt by the users on the flow. If this happens to data traffic, it may interrupt file transfer and corrupt the file.

 

 

Delay

4 Types of Delay

  • Processing Delay – time taken by router to process packets from an input interface and put them into the output queue of output interface
  • Queuing Delay – time a packet resides in the output queue of a router
  • Serialization Delay – time taken to place bits on the wire
  • Propagation Delay – time taken for packets to cross links from one end to the other end

 

 

Jitter

5 Jitter

  • Packets from a source will reach a destination with different delay times
  • Congestion on the network will cause jitter
  • Congestion can occur at a router interface/Service Provider network if the circuits are not properly provisioned

 

GNS3 1.4.2 and IOU VM.ova Installation Tips

Assumption 1: You’ve already have a VMware Workstation or Virtual Box installed and running on your PC/Laptop
Assumption 2: You’ve already downloaded GNS3 1.4.2 and GNS3 VM.ova files from “https://github.com/GNS3/gns3-gui/releases&#8221;.
Now Let’s get started:

Step1: Import “GNS3 VM.ova” file on your VMWare Workstation or Virtual Box

Step 1a: Upload IOU L2 and L3 image files on “http://192.168.56.101:8000/upload&#8221;, under IOU
Step 1b: Upload CiscoIOUKeygen.py file on “http://192.168.56.101:8000/upload&#8221;, under IOU

Step2: Install GNS3 1.4.2
Step 2a: complete basic GNS3 setup following YouTube videos.
One of the videos is as below: https://www.youtube.com/watch?v=1j4VHW-vvR8

Step3: SSH into your IOU VM machine, and go to “/etc” folder and run the following commands under respective folder.
(Video Reference: https://www.youtube.com/watch?v=V0SdjK5tEcA)

Tip: Default IOU VM UID = gns3
Default IOU VM PWD = gns3

Required commands:
echo -ne \\x1\\x0\\x0\\x0 > /etc/hostid
echo -ne \\x1\\x0\\x0\\x0 > /etc/ioukey
echo hostid = 0000001 ; echo hostname = gns3-iouvm ; echo ioukey = 3d9

Step 4: Go to http://192.168.56.101:8000/upload and upload CiscoIOUKeygen.py file

Step 5: Go to /opt/gns3/images/IOU directory and take ownership of the unloaded keygen file

Step 6: use python or python3 command to generate your 16 character long IOU key

root@gns3vm:/opt/gns3/images/IOU# python CiscoIOUKeygen.py
hostid=00000001, hostname=gns3vm, ioukey=25f

Add the following text to ~/.iourc:
[license]
gns3vm = acf51841caabfb0f;

You can disable the phone home feature with something like:
echo ‘127.0.0.127 xml.cisco.com’ >> /etc/hosts

============================================
***Notice that my VM machine works with python command but not python3 command!!!

root@gns3vm:/opt/gns3/images/IOU# chmod +x CiscoIOUKeygen.py

## Notice that python3 command does not work here!!!!
root@gns3vm:/opt/gns3/images/IOU# python3 CiscoIOUKeygen.py
File “CiscoIOUKeygen.py”, line 11
print “hostid=” + hostid +”, hostname=”+ hostname + “, ioukey=” + hex(ioukey)[2:]
^
SyntaxError: invalid syntax
==============================================

Step 7: Using the “gns3vm’ value, create a txt file containg the license information. Save the file as IOURC.txt and point your GNS3 remote server to this txt file.

[license]
gns3vm = acf51841caabfb0f;

CCNA Data Center 640-911 DCICN – Note 18, IPv6 Introduction

This is my first blog in 2016, I have been on holiday mode as I have been on one the longest annual leave in my life. Hope you understand the family commitment when you and your kids are on summer holiday (here in Sydney, Dec/Jan/Feb is blazing summer).

 

IPv6, the history and does it really matter to you or anyone?

The simple answer is YES, then why? The single biggest driver behind the development and introduction of IPv6 is  a long prediction of lack of usable IPv4 IP addresses since the explosion of World Wide Web (www) in 1995. The www development goes back to 1991 and then the introduction of grandfather web browser, Mosaic was first introduced in 1993. By year 1995, one third of IPv4 addresses were consumed, by year 2000, half of all IPv4 addresses were use.

As reviewed in previous notes, IPv4 consists of 32 bit address structure and theoretically that should give us 2 to the power of 32 IP addresses, that is 4294967296 IP addresses or roughly, 4.3 billion IP addresses . But not all IP addresses are usable such as the reserved IP addresses for private network use as well as the Class E addresses reserved for development and testing purposes. In other words, only around 2.5 billion IP addresses are true usable addresses. If you just check out our world’s population today ( http://www.worldometers.info/world-population/, China = 1.407 billion and India = 1.2912 billion people,), just looking at top two countries’ population figures, you can feel the IPv4 address shortage on your skin. The trend is that the world’s network has been doubling in size every year for the past 15 years. (https://en.wikipedia.org/wiki/IPv4_address_exhaustion)

With the advancement of new technologies comes the rapid deletion of available IPv4 IP addresses. Anything that’s related to mobile communications and entertainment as well as all other areas seems to be needing more and more IP addresses for everyday use. In the past, it was expected that all the IPv4 addresses would be depleted by 2011 but it is 2016 and we are still using IPv4 address without much thought, all thanks to the counter measures put into place to slow down the IPv4 IP address deletion. e.g.) The fine art of sub-netting, a practical use of DHCP and IP Natting.

 

 Quick note on history of IPv6:

1990 – IETF had predicted that all class B IPv4 IP addresses will be deleted by 1994
1991 Nov – IETF formed  ROAD (ROuting and ADress) Group in Santa Fe, US.
1995 – IPNG (IP Next Generation) Workgroup had written and submitted ‘RFC 1883’, this RFC has become the foundation of current IPv6.
1996 – 6Bone was introduced. 6Bone was a test-bed for IPv6 vulnerabilities connecting 57 countries across 1100 sites.
1999 – IPv6 Forum was launched to standardize the use of IPv6
2006 Jul 06 – 6Bone was decommissioned after 10 years of testing.
Current – Majority of IP products are manufactured with IPv6 capabilities and compatibility. IPv6 is slowly phasing out IPv4 around the world.

Source: https://en.wikipedia.org/wiki/IPv6

 

Quick note on 10 Advantages (Characteristics) of IPv6:
1. Larger IP address space than IPv4, 32 bits based IPv4 vs 128 bits based IPv6
2. Better end-to-end connectivity than IPv4
– peer-to-peer application connections such as games, video conferencing, file sharing and VoIP
– No need to use NAT as the shortage of addresses is thing of IPv4
3. Plug-n-Play feature of IPv6
– plug-and-play auto-configuration, e.g.) DHCPv6
4. Simplified Header structures leading to faster routing
5. Better security features
– use of IPSec (a built-in feature)
6. Improved QoS features
7. Improved Multicast and Anycast abilities
8. Better mobility features
9. Ease of administration over IPv4
10. IPv6 follows the key design principles of IPv4

Source: http://www.ipv6.com/articles/general/Top-10-Features-that-make-IPv6-greater-than-IPv4.htm

In the next section, we will look at some characteristics of IPv6 and then in the final section of IPv6, I will demonstrate IPv6 in a simple lab. Happy blogging, reading and all the best with your learning and career in 2016.

Cisco APE’s TIP: Configuring a Cisco Router as an Authoritative NTP Server

Why NTP matters to your network?

It is all about time precision and all systems in your infrastructure running on the same time. Network Time Protocol (NTP) is a critical service for all IP devices. Servers and network devices need to synchronize with a reliable time source such as an NTP server.

 

Real life scenario:

Scenario: Client is using a Windows 2012 Server running Windows 32 Time Services (W32TM) as their only NTP server. Which is not a full NTP deployment and Cisco devices have been pointed to this server, but Cisco IOS devices cannot synchronize time with Windows NTP server. Cisco recommends Linux or IOS based devices to provide this NTP services to other devices. This is a real life scenarios based on my client’s network.

 

 

Pre-task: Synchronize hardware clock to software clock

Why? Most of Cisco routers have two clocks, one, a battery-powered hardware clock, a.k.a ‘calendar clock’ and a software clock, a.k.a ‘(software) clock’ in the IOS CLI.

 

Step 1: Check the software clock:

R1#show clock

12:57:03.186 AEDST Fri Dec 11 2015

 

R1#show calendar

12:44:30 AEDST Fri Dec 11 2015

 

As you can see, there is more than 12 minute time drift between the software and hardware clocks.

 

 

Step 2: Now synchronize the hardware time to the software time.

R1#conf t

R1(confg)#ntp update-calendar

 

Step 3: Now check the time synchronization:

R1#show clock

12:59:31.88 AEDST Fri Dec 11 2015

R1#show calendar

12:59:31 AEDST Fri Dec 11 2015

 

Excellent! Now both software and hardware clocks showing the same time. You are ready to configure your IOS as NTP server.

Note: if you don’t use ‘ntp update-calendar’, NTP services on the router will still work, but it will use the software clock time, so ‘show clock’ time.

 

 

Task: Configure your router (R1) as an Authoritative NTP Server

 

Step 1: Check NTP source interface

R1# show run | begin interface Loopback0

interface Loopback0

ip address 10.10.10.1 255.255.255.255

 

 

Step 2: Actual configuration to make the router an NTP server

R1# conf t

R1(confg)#ntp master 2           <<<I am leaving stratum 1 for atomic clock, it will use its internal IP as its source of time, so 127.127.1.1 will become stratum 1, its loopback0 will take stratum 2.

R1(confg)#ntp server loopback 0  <<<Use loopback0 as NTP server

R1(confg)#ntp source loopback0   <<<Use loopback0 as NTP source

 

Optional commands:

R1(config)#(clock timezone (any name) (timezone)

 

 

Step 3: Using R1’s time on another device (R2). Now synchronize R2’s time with R1’s time (NTP time).

R2# conf t

R2(confg)#ntp server 10.10.10.1  <<<10.10.10.1 is the IP of R1’s loopback0

 

Step 4: Wait for 1-5 mins and run show clock command for verification.

R1#show clock

13:09:30.77 AEDST Fri Dec 11 2015

R2#show clock

13:09:30.77 AEDST Fri Dec 11 2015

 

 

Useful commands:

show ntp status

show ntp association