Fundamentals of Quality of Service (QoS) (Notes):

Thanks to all time best Cisco instructor Kevin Willis for sharing his video on Youtube! I watched his video to revist QoS fundamentals and re-consolidate previous knowledge. KW, you’re a Legend!

 

 “Quality of Service is a managed unfairness.”

Agenda

  1. Learn QoS Mechanisms
  • QoS is like a tool box with various number of tools, not just one thing
  1. Understand QoS Markings
  • how do we mark different traffics
  1. Demystify Weighted RED
  • Weighted Random Early Detection
  1. Select Appropriate Queuing
  • g.) LAN is running 1GB but WAN network is only 10mb, how does the router handle the 100:1 speed ratio,
  • High priority traffic such as Real-time streaming video or voice vs download/gaming traffic?
  1. Explain the ‘Token bucket’
  2. Configure QoS using MQC

 

Fundamentals of Quality of Service (QoS):

 “Quality of Service is a managed unfairness.”

  1. Learn QoS Mechanisms

If you have all different application fighting for the same bandwidth, you have to decide based on the characteristics of each traffic. Know what the applications are and what the business needs are.

 

10Gb links everywhere, no big deal to have a QoS.

Even within LAN, on high speed network the aggregation point becomes a bottleneck.

 qos1.png

 

IntServ =  RSVP (Resource Reservation Protocol). Sometimes called “hard-QoS”. Bandwidth is pinned-up (reserved) so a certain traffic can use on demand. These days, we rarely see IntServ in use due to inflexible nation of this QoS mechanism.

DiffServ = Differentiated Service. Router will differentiate different traffic types. Put different traffic types for different class. Create no more than 11 different traffic (if everyone is special, nobody is special) <<<Cisco recommendation.

Best effort = FIFO, first in firs served. No QoS enabled.

 

Common QoS Mechanisms – QoS is not a single tool that you just activate. QoS is a collection of tools.

  1. Classification and Marking

e.g.) Boarding pass for an airline – priority marking on boarding pass

Cisco tells us to classify your traffic into no more than 11 network traffic types. Classify and mark the traffic as early as possible on your network, changing bits on the header. Routers and switches can look at the header information and quickly decide whether to forward/drop packets, so the decision becomes really fast. Use access lists (NBAR) to do this. Once the traffic is classified, put the marking on it. However, classification and marking alone does not do anything.

 

  1. Queuing

E.g.) 1GB or 10GB Switch network traffics coming into router network with 10MB link out. If we had FIFO. We only have a limited amount of memory to queue all traffics, once the queue buckets fill-up, the excess traffics will start dropping overflowing from the single bucket. So to make this more efficient based on different traffic’s characteristics, this bucket can be sub-divided into a few smaller buckets, then different traffic can fill-up and use different buckets with varying priorities.

Mark the traffics and it can be put into different buckets. e.g.) VoIP goes into different bucket vs Best effort traffic. Typically VoIP traffic gets DSCP 46 (Differentiated Services Code Point). If VoIP is marked with a DSCP of 46, then put this traffic into one bucket. Everybody else can go into the other bucket. This is called queue separation. Even though the Best Effort buckets gets full and start dropping packets, the VoIP bucket will fill up occasionally and will not get full and impacted by the Best Effort bucket’s performance.

qos2

Cisco has many tools to help us on how to manage queues and dictate emptying these queues. Different Queue mechanisms supported on Cisco IOS?  Weighted Fair Queuing, Class-based weighted Queuing, Low Latency Queuing, Priority queuing, Custom Queuing, In the real world scenario, Class-based weighted Queuing and Low Latency Queuing are most often used.

The beauty of queuing is that it can protect certain traffic just simply separating different traffics into different buckets.

 

  1. Congestion Avoidance

RED – Random Early Detection, drop random traffic for the good of many.

 

  1. Policing and Shaping

Traffic conditioners

Policing – sets speed limit, if some packet is trying to transmit more than allowed, policing drops any exceeding traffic packet and these traffics must be retransmitted if they are TCP packets. If this is UDP packets, there is no retransmission.

Shaping – also sets speed limit, but softer, not enough bandwidth, buffer (delay) the packets and then send them off.

 

  1. Link Efficiency

Not as important as it used to be as we have higher WAN links these days.

  1. Link Fragmentation and Interleaving (LFI) = Sometime on the network on a slow speed link (56kbps link), there is a 1500byte data packet queued up and tiny voice packet has been queued up behind this packet. 214ms to send 1500bytes through 56kbps link.

 

Voice packet speed requirement:

<150ms transmission speed is OK.

>150ms = will start to get bad

>200ms = really get bad

 

E.g.) Analogy, metaphor – Caught at Traffic light and three trailer truck (Data packet) is in front of your sports car (voice packet). Fragment the 3 trailers and send them, but the sports car can swivel through them and get passed through. One issue: due to fragmentation, now you have three headers on each of the trailer, so increased header size. @768kbps (WAN link), if you are sending voice over IP, if less than 768kbps speed, use of LFI will help. If 768kbps or more, do not use LFI, it will hurt the network more than helping.

 

  1. Compression – sending the same amount of data using less bandwidth

The main use on today’s network is ‘RTP header compression’

RTP (Real Time Protocol) is a L4 protocol, depending on what sort of codec we use, the size of the payload could be 20 bytes, add L3 IP header + L4 UDP header + L4 RTP header = 40 bytes of header alone. Your header is 2 times the size of your payload. The payload to header ratio is 1:2. Turn on RTP header compression on the router interface. The routers looks at the voice packets arriving on its interface and see the commonalities between every packets in the same communication, it seems like every packet has the same destination IP address, same source and destination port IDs, why are we sending the same information multiple times? On each end routers, keep the copy of this information and send much smaller header (either 2 bytes or 4 bytes. 4 bytes have checksum. Generally on Cisco devices, it will use 2 bytes). The 2 bytes header contains the session context identifier (CID) which differentiates one voice conversation with another voice conversation. At the far end router, the router uses CID to identify the voice traffic and put the cached header copies onto the coming in traffic and send out to the LAN network.

 

 2. Understand QoS Markings

qos3

L2 marking = Class of Service (CoS)

ISL = not used

IEEE802.1Q = 4 bits added, (3 bits = 8 values (0-7) bits.)

 

6 and 7 bits = reserved for network use

cos 5 = voice traffic

DSCP Values:

CS (Class Selector)

Issue: Only layer 2 marking, if it goes out through a Router, it gets written over.  So, this has to be rewritten at L4 header using Type of Service (TOS) Bytes.

qos4.png

We can use three left bits; we can use IP Precedence (CoS matching only gives 6 classes of traffic as we cannot use 6 & 7 bits as in CoS). IP Precedence is not scalable. We now use DSCP using 6 bits in ToS byte – 0-63 DSCP values can be used. The 64 values gave too many options, so ITF decided to define commonly used DSCP values to set up certain standards.

 qos5

ITF preselected 21 names Per Hop Behaviours (PHB), we can use the number or names that corresponds to ITF names.

qos6

 

 DSCP/PHB Value for Enterprise traffics.

사용자 지정 20

 

  1. Demystify Weighted RED

 Random Early Detection (RED)

사용자 지정 16

When we get to certain level (Min. threshold), start introducing the possibility of dropping. As it moves up and hit the Max Threshold, the chances of dropping packets get bigger.

 사용자 지정 17

 MPD = Mark Probability Denominator

 Cisco IOS already has MPD values, but this can be manipulated. The following is WRED profiles suggested by Cisco.

 사용자 지정 18

  

Explicit Congestion Notification (ECN)

https://www.juniper.net/documentation/en_US/junos/topics/concept/cos-qfx-series-explicit-congestion-notification-understanding.html

Uses the 7th bit in ToS Byte for ECT and 8th bit for CE.

The receding router can mark the ECT and CE bits to binary 1’s and ask the other router to slow down. Otherwise, the packets gets dropped and then the TCP slow-start will kick-in (TCP windowing concept, where the window size is doubled continuously until it reaches threshold value and it drops down and TCP slow-start kicks in.)

 사용자 지정 19

 

 

  1. Select Appropriate Queuing

CB-WFQ vs LLQ

사용자 지정 25

Cisco recommends us to use no more than 11 traffic classes, but one class already is created by default, “class-default”.  Catch-all traffic class, so we can use 12 classes of traffic.

  • class-default uses FIFO.
  • CB-WFQ – during the time of congestion when QoS kicks in, give minimum of x Mbps of bandwidth, but give more if more bandwidth is available.
  • LLQ (priority) queue – during the time of congestion, give up to 3Mbps of bandwidth, but nor more that 3Mbps.

E.g.) Car pool lane or bus lane – if you have more passengers, you have rights to use the special lane, but still needs to keep the speed-limit.

 

  1. Explain the ‘Token bucket’

Using Frame-relay network, speed of 128kbps.

How do you send data at the half the rate of the line speed? of if the full line speed is 128kbps, send at 64kbps speed. Use the analogy of car traveling at 100km/h to reach 50kms in 0.5 hours.

Send & stop, send & stop, this is how the policing and shaping does its magic.

 사용자 지정 26

 

  1. Configure QoS using MQC

고정된 영역 1

고정된 영역 2

고정된 영역 3

 

고정된 영역 4

 

 

 

MQC Demo

QoS configuration is a 3 steps process:

 

Step 1: Create Class-maps

#classify EMAIL TRAFFIC

R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#class-map ?

WORD       class-map name

match-all  Logical-AND all matching statements under this classmap

match-any  Logical-OR all matching statements under this classmap

type       Configure CPL Class Map

 

R1(config)#class-map match-any EMAIL

R1(config-cmap)#match protocol pop3

R1(config-cmap)#match protocol imap

R1(config-cmap)#match protocol exchange

R1(config-cmap)#match protocol smtp

R1(config-cmap)#exit

 

R1(config)#class-map VOICE

R1(config-cmap)#match protocol rtp ?

audio             Match voice packets

in-app-hierarchy  Match protocol in transport hierarchy

payload-type      Match an explicit PT

potentially       Match protocol, and all potentiall traffic

video             Match video packets

<cr>

R1(config-cmap)#match protocol rtp audio

 

R1(config-cmap)#exit

 

#WEB TRAFFIC

R1(config)#class-map match-any WEB

R1(config-cmap)#match protocol http

R1(config-cmap)#match protocol secure-http

 

#SCAVENGER TRAFFIC

R1(config)#class-map SCAVENGER

R1(config-cmap)#match protocol bitt

R1(config-cmap)#match protocol bittorrent

R1(config-cmap)#exit

 

R1#show class-map

Class Map match-any class-default (id 0)

Match any

 

Class Map match-any EMAIL (id 1)

Match protocol pop3

Match protocol imap

Match protocol exchange

Match protocol smtp

 

Class Map match-any WEB (id 3)

Match protocol http

Match protocol secure-http

 

Class Map match-all VOICE (id 2)

Match protocol rtp audio

 

Class Map match-all SCAVENGER (id 4)

Match protocol bittorrent

 

 

Step 2: Create Policy-maps

R1(config)#policy-map QOS-LAB1

R1(config-pmap)#?

Policy-map configuration commands:

class        policy criteria

description  Policy-Map description

exit         Exit from policy-map configuration mode

no           Negate or set default values of a command

R1(config-pmap)#class EMAIL

R1(config-pmap-c)#?

Policy-map class configuration commands:

admit            Admit the request for

bandwidth        Bandwidth

compression      Activate Compression

drop             Drop all packets

exit             Exit from class action configuration mode

fair-queue       Enable Flow-based Fair Queuing in this Class

flow             Flow subcommands

log              Log IPv4 and ARP packets

measure          Measure

netflow-sampler  NetFlow action

no               Negate or set default values of a command

police           Police

priority         Strict Scheduling Priority for this Class

queue-limit      Queue Max Threshold for Tail Drop

random-detect    Enable Random Early Detection as drop policy

service-policy   Configure QoS Service Policy

set              Set QoS values

shape            Traffic Shaping

 

R1(config-pmap-c)#set dscp af13

R1(config-pmap-c)#bandwidth 512 <<<give this command first before giving ‘random-detect’ command

R1(config-pmap-c)#end

R1(config-pmap-c)#random-detect ?

atm-clp-based                   Enable atm-clp-based WRED as drop policy

clp                             parameters for each clp value

cos                             parameters for each cos value

cos-based                       Enable cos-class-based WRED as drop policy

discard-class                   parameters for each discard-class value

discard-class-based             Enable discard-class-based WRED as drop

policy

dscp                            parameters for each dscp value

dscp-based                      Enable dscp-based WRED as drop policy

ecn                             explicit congestion notification

exponential-weighting-constant  weight for mean queue depth calculation

precedence                      parameters for each precedence value

precedence-based                Enable precedence-based WRED as drop policy

<cr>

 

R1(config-pmap-c)#random-detect dscp-based <<<default is using cos, this command enables dscp based WRED

R1(config-pmap-c)#random-detect ecn <<<turns on ECN

R1(config-pmap-c)#exit

R1(config-pmap)#class VOICE

R1(config-pmap-c)#priority 256 <<<Enabled LLQ, go first

R1(config-pmap-c)#random-detect dscp-based <<<Since voice traffic is RTP encapsulated in UDP, TCP slow-start will not help us. So, no need to use ECN bits. No need to use WRED.

Must deconfigure priority in this class before issuing this command

R1(config-pmap-c)#exit

R1(config-pmap)#class WEB

R1(config-pmap-c)#bandwidth 768

R1(config-pmap-c)#exit

R1(config-pmap)#class SCAVENGER

R1(config-pmap-c)#police 128000 <<<Set the maximum bandwidth using Policing. This is in bps (bits) not Bps (Bytes).

R1(config-pmap-c-police)#exit

R1(config-pmap-c)#exit

R1(config-pmap)#exit

R1#show policy-map

Policy Map QOS-LAB1

Class EMAIL

set dscp af13

bandwidth 512 (kbps)

Class VOICE

priority 256 (kbps)

Class WEB

bandwidth 768 (kbps)

Class SCAVENGER

police cir 128000 bc 4000

conform-action transmit

exceed-action drop

 

#Marking only can be done on the inbound traffic.

#Shaping can only be applied to outbound traffic.

#Policing can be applied to either directions.

 

R1#conf t

R1(config)#int gi0/0

R1(config-if)#service-policy output QOS-LAB1 <<<Apply configuration to outgoing traffic

R1(config-if)#end

 

R1#show policy-map interface gi0/0

GigabitEthernet0/0

 

Service-policy output: QOS-LAB1

 

queue stats for all priority classes:

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

 

Class-map: EMAIL (match-any)

0 packets, 0 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: protocol pop3

0 packets, 0 bytes

5 minute rate 0 bps

Match: protocol imap

0 packets, 0 bytes

5 minute rate 0 bps

Match: protocol exchange

0 packets, 0 bytes

5 minute rate 0 bps

Match: protocol smtp

0 packets, 0 bytes

5 minute rate 0 bps

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

QoS Set

dscp af13

Packets marked 0

bandwidth 512 kbps

 

Class-map: VOICE (match-all)

0 packets, 0 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: protocol rtp audio

Priority: 256 kbps, burst bytes 6400, b/w exceed drops: 0

 

 

Class-map: WEB (match-any)

0 packets, 0 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: protocol http

0 packets, 0 bytes

5 minute rate 0 bps

Match: protocol secure-http

0 packets, 0 bytes

5 minute rate 0 bps

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

bandwidth 768 kbps

 

Class-map: SCAVENGER (match-all)

0 packets, 0 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: protocol bittorrent

police:

cir 128000 bps, bc 4000 bytes

conformed 0 packets, 0 bytes; actions:

transmit

exceeded 0 packets, 0 bytes; actions:

drop

conformed 0000 bps, exceeded 0000 bps

 

Class-map: class-default (match-any)

3 packets, 180 bytes

5 minute offered rate 0000 bps, drop rate 0000 bps

Match: any

 

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 3/180

 

Advertisements

Cisco UCM CAR (CDR) Web GUI Access Request (https:///car/)

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/admin/11_5_1_SU1/Administration/cucm_b_administration-guide-1151su1/cucm_b_administration-guide-1151su1_chapter_010.pdf

 

To provide a user to CAR (CDR)  (https://<CAR server IP Address>/car/) web page, the following two access groups must be associated with the user. After giving user this access, please test login to other areas of UCM GUI, so the users do not gain unapproved access to UCM Admin pages.

 

  1. Standard CCM End Users
  2. Standard Admin Rep Tool Admin = (Standard CAR Admin Users, Standard CCM Super Users)

 

CAR web gui

Interview question: Cisco Voice Engineer: CUCM Database replication value, do you know what you are talking about?

This is a helpful reminder note for all who manages CUCM on day-to-day basis and one of the favorite Voice/IPTel Engineer interview questions. I think I was asked this question in almost every voice Engineer role interviews. Good luck with your next interview!

Q1. What does CUCM database replication value mean to you (CM Administrator)? 

2 = Good, excellent, no behind pain

Other than 2 = Behind pain begins

Value Meaning Description
0 Initialization State This state indicates that replication is in the process of trying to  setup. Being in this state for a period longer than an hour could  indicate a failure in setup.
1 Number of Replicates not correct This state is rarely seen in 6.x and 7.x but in 5.x can indicate its  still in the setup process. Being in this state for a period longer than  an hour could indicate a failure in setup.
2 Replication is good Logical connections have been established and tables match the other servers on the cluster.
3 Tables are suspect Logical connections have been established but we are unsure if tables match.
In 6.x and 7.x all servers could show state 3 if one server is down in  the cluster.
This can happen because the other servers are unsure if  there is an update to a user facing feature that has not been passed  from that sub to the other device in the cluster.
4 Setup Failed / Dropped The server no longer has an active logical connection to receive  database table across. No replication is occurring in this state.

Source: CCO

Q2. How to check?

Option 1: On CUCM OS CLI, run show command

admin:show perf query class “Number of Replicates Created and State of Replication”
==>query class :

– Perf class (Number of Replicates Created and State of Replication) has instances and values:
ReplicateCount -> Number of Replicates Created = 427
ReplicateCount -> Replicate_State = 2 <<< Life is Good

Option 2: On CUCM Unified Reporting 

Cisco Unified Reporting > System Reports > Unified CM Database Status >> Run report

 

%ec%82%ac%ec%9a%a9%ec%9e%90-%ec%a7%80%ec%a0%95-12%ec%82%ac%ec%9a%a9%ec%9e%90-%ec%a7%80%ec%a0%95-13

Option 3: Real Time Monitoring Tool (RTMT)

Install RTMT plugin on your desktop. Launch RTMT and then go to “Call Manager > Service > Database Summary”

Q3. How to repair a broken db replication issue?

I have come acorss a very good blog and it shows you on how to repair a broken db replication. Click here.

 

 

 

Notes on Cisco QoS: Clearing the fog – Part 2. Quality issues

Quality of Service

QOS = Method of giving priority to some specific traffic as moving over the network.

The basic aim of QoS is to have a consistent and predictable performance on your network.

 

1 qos intro

General characteristics of today’s Converged Network:

  • Small voice packet compete with bursty data packets, many different applications are using network as services
  • Critical traffic must get priority over less critical traffic, without QoS, default behavior is First In First Out (FIFO)
  • Voice and video traffics are time-sensitive
  • Outages are not acceptable

 

Converged Network Quality issues:

  • Lack of Bandwidth
  • Packet Loss
  • Delay
  • Jitter

 

Bandwidth

2 Bandwidth Measure.png

  • Maximum available bandwidth is the slowest link on the traffic paths
  • On the same physical links (traffic paths), multiple flows compete for the same bandwidth, multiple applications sharing the same bandwidth
  • Lack of bandwidth causes performance degradation on network applications

 

 

Packet Loss

3 Tail Drop due to Queue Congestion

Packet loss due to Tail Drop: Queue only can so much packets and once it is full and more packets arrive at the tail end of the queue before the queue is emptied (due to link congestion etc.), the packets will be dropped, and this behavior is called ‘Tail Drop’. If the tail drop occurs to the time sensitive traffics such as voice and video, the effects are immediately felt by the users on the flow. If this happens to data traffic, it may interrupt file transfer and corrupt the file.

 

 

Delay

4 Types of Delay

  • Processing Delay – time taken by router to process packets from an input interface and put them into the output queue of output interface
  • Queuing Delay – time a packet resides in the output queue of a router
  • Serialization Delay – time taken to place bits on the wire
  • Propagation Delay – time taken for packets to cross links from one end to the other end

 

 

Jitter

5 Jitter

  • Packets from a source will reach a destination with different delay times
  • Congestion on the network will cause jitter
  • Congestion can occur at a router interface/Service Provider network if the circuits are not properly provisioned

 

CUBE High Availability (HA) Using HSRP Configuration with port-channel twist

Starting with Cisco Gen2 router platforms, CUBE can provide the HSRP (Hot Standby Routing Protocol). That is you need two CUBE routers to confgure this setup. HSRP basically works on Active and Standby mode between two routers by monitoring both the inside and outside interfaces, if Active side goes down, then the Standby device becomes active and takes over the responsibilities of the Active router.

In CUBE HSRP Active/Standby pair scenario, the two CUBE routers keep exchange communications over the same virtual IP address. This setup will support media preservation over an HSRP switchover of SIP to SIP calls, but not the call signaling. Call signaling preservation is supported from IOS 15.2.3T.

Requirements:
1. Two identical ISR G2 routers with the correct IOS and license
*Cisco 2951 (x 2), IOS = c2951-universalk9-mz.SPA.154-3.M1, license =SL-29-UC-K9
2. Identiacal CUBE configuration
3. SIP-to-SIP call flows
Configuration:
1. Enable CUBE and CUBE Redundancy

Enable CUBE on CUBE01 and CUBE02:
voice service voip
mode border-element
allow-connections sip to sip

Enable CUBE redundancy and call checkpointing on both CUBES
voice service voip
redundancy
2. Enable HSRP

Enable router redundancy schemes on both routers, where:
scheme – redundancy state tracking scheme
standby – enable standby (HSRP) state tracking scheme
SB – the HSRP standby group name

redundancy inter-device
scheme standby SB

3. Configure HSRP Communication Transport

Configure the HSRP Inter-Device Communication Transport as follows:

Active Configuration:
ipc zone default <<< For Inter-Device Communication Protocol (IPC)
association 1 <<< Associates between two devices
no shutdown <<< Enables associations
protocol sctp <<< Stream Control Transmission Protocol (SCTP) for communication language
local-port 5000 <<< Defines the local SCTP port number
local-ip 10.10.24.14 <<< Defines the local router’s IP address
remote-port 5000 <<< Defines the remote SCTP port number
remote-ip 10.10.24.13 <<< Defines the remote router’s IP address

Standby Configuration:
ipc zone default
association 1
no shutdown
protocol sctp
local-port 5000
local-ip 10.10.24.13
remote-port 5000
remote-ip 10.10.24.14

4. Configure HSRP on the Interfaces

Configure the HSRP Inter-Device Communication Transport as follows:

Active Configuration

interface Port-channel1
description CUBE01 interface
ip address 10.10.10.11 255.255.255.0
standby delay minimum 30 reload 60 <<< Avoids race condition to establish contact between Active and Standby
standby version 2
standby 0 ip 10.10.10.1
standby 0 priority 50
standby 0 preempt
standby 0 name SB

interface GigabitEthernet0/0
no ip address
duplex full
speed 1000
channel-group 1

interface GigabitEthernet0/1
no ip address
duplex full
speed 1000
channel-group 1
Standby Configuration:

interface Port-channel1
description CUBE02 interface
ip address 10.10.10.12 255.255.255.0
standby delay minimum 30 reload 60
standby version 2
standby 0 ip 10.10.10.1
standby 0 priority 50
standby 0 preempt
standby 0 name SB

interface GigabitEthernet0/0
no ip address
duplex full
speed 1000
channel-group 1

interface GigabitEthernet0/1
no ip address
duplex full
speed 1000
channel-group 1
5. Configure the HSRP Timers

CUBE01(config-if)#standby 0 timers 2 msec 40 <<< configures failover and hold timers

CUBE02(config-if)#standby 0 timers 2 msec 40
6. Configure the Media Inactivity Timer

Enables the Active/Standby router pair to monitor and disconnect calls if no Real-Time Protocol (RTP) packets are received within a configurable time period. Default value is 28 seconds.

ip rtcp report interval 3000
gateway
media-inactivity-criteria all
timer receive-rtp 86400
timer receive-rtcp 5
7. Configure SIP Binding to HSRP Address

voice service voip
mode border-element license capacity 125
allow-connections sip to sip
redundancy
sip
bind control source-interface Port-channel1
bind media source-interface Port-channel1
asserted-id pai
asymmetric payload full
midcall-signaling passthru
privacy-policy passthru
sip-profiles 100
8. Reload the Routers

Active Router
CUBE01#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured

Standby Router
CUBE02#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
9. Point Attached Softswitches to the CUBE HSRP Virtual Address
On CUCM, this is configured on the SIP Trunk configuration under Device > Trunk.

SIP Trunk

 

**********************************************
Useful commands for verification and troubleshooting:
show redundancy inter-device
show redundancy states
show standby brief
show standby
show voice high-availability summary
show voice high-availability summary | include media
show voip rtp connection
show sip-ua status
show sip-ua statistics
debug standby

show process cpu history
show process cpu sorted

***********************************************

Notes on Cisco QoS: Clearing the fog – Part 1. Basic Introduction

  1. What is Quality of Service (QoS) ?

Analogy 1: QoS is a network tool which can be implemented to effectively transport more critical traffics over IP, which gives critical traffic a priority over less critical traffic.

Analogy 2: QoS is a method of giving a priority to some specific data traffic going across our network.

  • Give VoIP, Video traffic more priority than ftp file downloading traffic
  • Some critical Data such as Citrix etc.

 

  1. Converged Network Quality Issues

Today’s enterprise network Characteristics:

  • Benign small voice packet flows compete directly with busty data packet flows.
  • Voice load and voice application data (traffic) tolerate minimal variation in delay, packet loss or jitter. The voice quality degradation is immediately felt by the users.
  • Give critical traffic higher priority
  • Voice and video are real-time, hence time-sensitive
  • Outage/packet drops are not acceptable

 

Some issues from Converged Network:

  • Lack of bandwidth – If more traffic is pumped through the network more than the network can handle, there will be congestions and packet loss.
  • Packet Loss – If input queue pumps too much packets into an interface, output queue fills up, the packet is dropped.
  • Delay –
    • Processing delay – The time it takes for a router to take the packet from an input interface, examine it and put it into the output queue of the output interface
    • Queuing delay – The time a packet resides in the output queue of a router
    • Serialization delay – The time it takes to place the “bits on the wire”
    • Propagation delay – The time it takes for the packet to cross the link from one end to the other

 

  • Jitter –
    • Packets from the source will reach the destination with different delays
    • Jitter is generally caused by congestion in the IP network
    • The congestion can occur either at the router interfaces or in a provider or carrier network if the circuit has not been provisioned properly

 

To overcome these converged network quality issues, QoS tool(s) must be used based on each network.

 

Some Cisco recommended QoS tool types and their characteristics:

A. Best effort

– Out of box, if you do not configure your devices, it is using best effort

– Business network with no QoS policies

– Infrastructure does not support QoS

– FIFO

 

B. Integrated Services (IntServ)

– Aims to reserve bandwidth along a specific path in the network

– Guarantees end-to-end bandwidth for mission-critical applications such as VoIP and Citrix

– End-hosts signal their QoS requirements to the network (Signalled QoS model)

– Every communication stream needs to request resources from the network.

– Edge routers use Resource Reservation Protocol (RSVP) to signal and reserve bandwidth

 

Some disadvantages of IntServ:

– Every device along the network must be fully RSVP aware and have ability to process QoS

– Reservations in each devices along the path need to be periodically refreshed, adds traffic and overhead along the network

– “Soft-states” or bandwidth reservation increase memory and CPU requirements on devices along the path

– Adds complexity to the network which makes network infrastructure difficult to maintain

 

C. Differentiated Service (DiffServ)

– Designed to overcome the limitations of Best-Effort and IntServe model, while maintaining the ability to provide an almost guaranteed QoS

– Routers and switches are configured to service multiple classes of traffic with different priorities. Bandwidth, delay and prioritization are configured on a hop-to-hop basis along the network infrastructure, making diffServ cost-effective and scalable

– For DiffServ QoS to work, network traffic must be divided into classes that are based on the company’s requirements

– Network devices identify traffic as it passes through them and enforce the configured policies, making sure that each class/service is served as instructed

 

Reference:

http://docwiki.cisco.com/wiki/Quality_of_Service_Networking

http://searchunifiedcommunications.techtarget.com/tip/DiffServ-QoS-model-works-wonders-for-VoIP-networks