Chasing Packets in GNS3 & Production Environment, Part 2: IOS Embedded Packet Capture & tee off to a TFTF server

aaa2

IOS Embedded Packet Capture Configuration in a nutshell:

r1#monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

r1#monitor capture point ip cef E0_0 e0/0 both

r1#monitor capture point associate E0_0 PAKCETBUFFER

r1#monitor capture point start E0_0

 

Generate some traffic: example showing ICMP traffic generation

aaa9

Generate some RTP traffic: example showing use of Cisco IP communicator in this lab

aaa11.png

 

r1#monitor capture point stop E0_0

r1#monitor capture buffer PAKCETBUFFER export tftp://172.168.10.10/mycapture.pcap

 

***You must specify the name of the file, otherwise the teeing off to TFTP server will not work!!!

 

aaa8

 

Example of ICMP traffic packet capture:

aaa10.png

 

Example of RTP traffic packet capture.

aaa7

 

 

=======================================================================

Actual configuration:

r1#monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

 

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 0

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Inactive

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

 

r1#mon cap point ip cef E0_0 e0/0 both

*Apr  5 07:30:22.526: %BUFCAP-6-CREATE: Capture Point E0_0 created.

 

r1#show mon cap point all

Status Information for Capture Point E0_0

IPv4 CEF

Switch Path: IPv4 CEF            , Capture Buffer: None

Status : Inactive

 

Configuration:

monitor capture point ip cef E0_0 Ethernet0/0.100 both

 

r1#mon cap point associate E0_0 PAKCETBUFFER

 

r1#show mon cap point all

Status Information for Capture Point E0_0

IPv4 CEF

Switch Path: IPv4 CEF            , Capture Buffer: PAKCETBUFFER

Status : Inactive

 

Configuration:

monitor capture point ip cef E0_0 Ethernet0/0.100 both

 

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 0

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Inactive

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

 

 

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 0

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 3

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 4

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 657

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Active

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

r1#mon cap point stop E0_0

r1#mon cap point stop E0_0

*Apr  5 07:34:11.582: %BUFCAP-6-DISABLE: Capture Point E0_0 disabled.

r1#show mon cap buffer PAKCETBUFFER parameters

Capture buffer PAKCETBUFFER (linear buffer)

Buffer Size : 2097152 bytes, Max Element Size : 128 bytes, Packets : 657

Allow-nth-pak : 0, Duration : 0 (seconds), Max packets : 0, pps : 0

Associated Capture Points:

Name : E0_0, Status : Inactive

Configuration:

monitor capture buffer PAKCETBUFFER size 2048 max-size 128 linear

monitor capture point associate E0_0 PAKCETBUFFER

 

 

r1#show monitor capture buffer PAKCETBUFFER dump

07:33:16.228 UTC Apr 5 2016 : IPv4 LES CEF    : Et0/0.100 None

 

F4E2C230: AABBCC00 0100000C 2978156D 81000064  *;L…..)x.m…d

F4E2C240: 08004560 0034EE83 40007F06 1959C0A8  ..E`.4n.@….Y@(

F4E2C250: 640B8EC8 400B0570 07D079AA FEBF61F3  d..H@..p.Py*~?as

F4E2C260: 050A5018 FAC0BFD0 00000400 00001100  ..P.z@?P……..

F4E2C270: 00000000 000000                      …….

… Content omitted for brevity

 

 

r1#monitor capture buffer PAKCETBUFFER export ?

disk0:  Location to dump buffer

disk1:  Location to dump buffer

ftp:    Location to dump buffer

http:   Location to dump buffer

https:  Location to dump buffer

pram:   Location to dump buffer

rcp:    Location to dump buffer

scp:    Location to dump buffer

snmp:   Location to dump buffer

tftp:   Location to dump buffer

unix:   Location to dump buffer

 

r1#monitor capture buffer PAKCETBUFFER export tftp://172.168.10.10/mycapture.pcap

!

***You must specify the name of the file, otherwise the teeing off to TFTP server will not work!!!

 

Advertisements

Chasing Packets in GNS3 & Production Environment, Part 1: Capturing packets using built-in Live Wireshark Capture in GNS3 1.4.4

Why do you want to do this lab?

You can capture any interesting packets and analyse for your learning purpose, analyzing packet captures can give you the real inside of how the packets are working on the devices and on different segments of the network. Simply reading the books and learn about how packets work behind the scenes is a little like trying to learn something as if you are three wise monkeys (see no evil, hear no evil, speak no evil).

On the real production, you can use other methods to capture interesting packets. Some examples are IOS Embedded Packet capture and tee off the configuration to a TFTP server, use a sniffer using spanning port or remote spanning port. Also, use more advanced method of Cisco NAM (Network Analyzer).

In this part, I will quickly show you how to whiz up a simple lab and capture some packets on GNS3 and Wireshark live capture within, GNS3. In the next section, I will demonstrate IOS Embedded Packet capture and teeing off to a TFTP server. Lastly, I will demonstrate packet capturing using spanning port and remote span.

Prerequisite 1: GNS3 1.4.4 pre-installed on Windows PC/laptop

Prerequisite 2: IOU VM ova deployed and integrated with GNS3

Prerequisite 3: Familiar with VMware workstation and Windows loopback configuration

 

Topology:

aaa1

Step 1: Add devices as below and make all connections. When you add the devices, your GNS3 topology will look like this. Remember to use dummy switches to make connection between your virtual machines and your host PC loopback to your IOU switches.

aaa2.png

Step 2: Configure your routers and switches similar to the configuration found in  the attached zip file.

r1

r2

sw1

sw2

 

Step 3: Capture packets using various link positions

aaa3

aaa4

If you run into the following error, you will have to go to GNS3 setting and update the path of Wireshark.

aaa5

=> Error: SW3: Could not start the packet capture reader: [WinError 2] The system cannot find the file specified: None

Changing path in GSN3 preferences:

C:\Program Files\Wireshark\wireshark.exe” ==> C:\Program Files (x86)\Wireshark\wireshark.exe

 

Step 4: Wireshark will open automatically and start capturing all the traffic on the link you have selected.

e.g.) TCP/IP packet capture example

aaa6.png

e.g.) Voice packet capture using soft phones (On virtual machines) between two work stations and CUCM.

aaa7

Now you can set up any server and clients and study how TCP/IP, UDP work behind the scenes. Jump straight in and try to enjoy your study!

 

Note: This lab can be completed on a single PC, Save Electricity, save Money, save Time, SAVE THE PLANET.

 

 

 

Notes on Cisco QoS: Clearing the fog – Part 4. Modular QoS Lab

Lab topology:

Module QoS 2

How this lab can be configured in GNS3 on a single PC.

  • SW1 and SW2 is the local GNS3 switches, merely serving as a connector between PC1 and HTTP Server respectively. These dummy switches must be used while connecting virtual machines to GNS3 devices.

Module QoS 1

Step 1: Configure R1 and R2 to allow communication between the networks.

R1 base configuration:

hostname R1

interface FastEthernet0/0
ip address 192.168.30.254 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
clock rate 2000000
!
router eigrp 1
network 1.0.0.0
network 192.168.30.0
auto-summary

==============================================

R2 base configuration:

hostname R2

interface FastEthernet0/0
ip address 192.168.40.254 255.255.255.0
duplex auto
speed auto

router eigrp 1
network 1.0.0.0
network 192.168.40.0
auto-summary

==============================================

Step 2: Configure R1 with Access List, class-map and policy-map

access-list 200 permit icmp host 192.168.30.30 host 192.168.40.40 echo
access-list 200 permit icmp host 192.168.30.30 host 192.168.40.40 echo-reply
access-list 100 permit tcp any any eq www

class-map match-all WEB_TRAFFIC
match access-group 100
class-map match-all ICMP_TRAFFIC
match access-group 200

policy-map MODULAR
class ICMP_TRAFFIC
bandwidth 256
class WEB_TRAFFIC
bandwidth 128
class class-default

Step 3: Apply policy map to output queue of Serial 0/0

!Apply Service-policy to output interface s0/0

interface Serial0/0
ip address 1.1.1.1 255.255.255.0
clock rate 2000000
 service-policy output MODULAR

==============================================

Step 4: Run quick check on the configuration

R1#show class-map
Class Map match-all WEB_TRAFFIC (id 1)
Match access-group  100

Class Map match-any class-default (id 0)
Match any

Class Map match-all ICMP_TRAFFIC (id 2)
Match access-group  200

R1#show policy-map
Policy Map CCIE
Class ICMP_TR
Bandwidth 128 (kbps) Max Threshold 64 (packets)
Class WEB_TR
Bandwidth 64 (kbps) Max Threshold 64 (packets)
Class class-default

==============================================

Before any ping or http traffic is sent across the WAN link

R1#show policy-map interface s0/0
Serial0/0

Service-policy output: MODULAR

Class-map: ICMP_TRAFFIC (match-all)
    0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 112
Queueing
Output Queue: Conversation 265
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: WEB_TRAFFIC (match-all)
      0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 120
Queueing
Output Queue: Conversation 266
Bandwidth 64 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
697 packets, 46091 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

==============================================

Step 5: Generate ICMP traffic by pining the server from the client PC

To generate ICMP traffic, from the client PC (192.168.30.30) ping http server at 192.168.40.40.
ICMP pinging

‘show policy-map interface s0/0’ after 8 ping messages have been sent from 192.168.30.30 (client) to 192.168.40.40 (Server)

R1#show policy-map interface s0/0
Serial0/0

Service-policy output: MODULAR

Class-map: ICMP_TRAFFIC (match-all)
8 packets, 512 bytes <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 112
Queueing
Output Queue: Conversation 265
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: WEB_TRAFFIC (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 120
Queueing
Output Queue: Conversation 266
Bandwidth 64 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
766 packets, 50456 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

==============================================

Step 6: Access web page of http server from the client PC

To generate some http traffic, access http://192.168.40.40/ from the client PC to HTTP Server.
Access IIS

==============================================

show policy-map interface serial0/0 after generating http traffic

R1#show policy-map interface s0/0
Serial0/0

Service-policy output: MODULAR

Class-map: ICMP_TRAFFIC (match-all)
    12 packets, 768 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 112
Queueing
Output Queue: Conversation 265
Bandwidth 128 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: WEB_TRAFFIC (match-all)
13 packets, 2539 bytes <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 120
Queueing
Output Queue: Conversation 266
Bandwidth 64 (kbps)Max Threshold 64 (packets)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0

Class-map: class-default (match-any)
878 packets, 57842 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

 

==============================================

R1#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Serial0/0
D       1.0.0.0/8 is a summary, 00:59:46, Null0
C    192.168.30.0/24 is directly connected, FastEthernet0/0
D    192.168.40.0/24 [90/2195456] via 1.1.1.2, 00:59:41, Serial0/0

 

R2#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Serial0/0
D       1.0.0.0/8 is a summary, 00:04:16, Null0
D    192.168.30.0/24 [90/2195456] via 1.1.1.1, 00:04:11, Serial0/0
C    192.168.40.0/24 is directly connected, FastEthernet0/0

 

All this lab was done on a laptop, go easy on the environment. 🙂

On a single PC

Notes on Cisco QoS: Clearing the fog – Part 2. Quality issues

Quality of Service

QOS = Method of giving priority to some specific traffic as moving over the network.

The basic aim of QoS is to have a consistent and predictable performance on your network.

 

1 qos intro

General characteristics of today’s Converged Network:

  • Small voice packet compete with bursty data packets, many different applications are using network as services
  • Critical traffic must get priority over less critical traffic, without QoS, default behavior is First In First Out (FIFO)
  • Voice and video traffics are time-sensitive
  • Outages are not acceptable

 

Converged Network Quality issues:

  • Lack of Bandwidth
  • Packet Loss
  • Delay
  • Jitter

 

Bandwidth

2 Bandwidth Measure.png

  • Maximum available bandwidth is the slowest link on the traffic paths
  • On the same physical links (traffic paths), multiple flows compete for the same bandwidth, multiple applications sharing the same bandwidth
  • Lack of bandwidth causes performance degradation on network applications

 

 

Packet Loss

3 Tail Drop due to Queue Congestion

Packet loss due to Tail Drop: Queue only can so much packets and once it is full and more packets arrive at the tail end of the queue before the queue is emptied (due to link congestion etc.), the packets will be dropped, and this behavior is called ‘Tail Drop’. If the tail drop occurs to the time sensitive traffics such as voice and video, the effects are immediately felt by the users on the flow. If this happens to data traffic, it may interrupt file transfer and corrupt the file.

 

 

Delay

4 Types of Delay

  • Processing Delay – time taken by router to process packets from an input interface and put them into the output queue of output interface
  • Queuing Delay – time a packet resides in the output queue of a router
  • Serialization Delay – time taken to place bits on the wire
  • Propagation Delay – time taken for packets to cross links from one end to the other end

 

 

Jitter

5 Jitter

  • Packets from a source will reach a destination with different delay times
  • Congestion on the network will cause jitter
  • Congestion can occur at a router interface/Service Provider network if the circuits are not properly provisioned

 

CCNA Data Center 640-911 DCICN – Note 18, IPv6 Introduction

This is my first blog in 2016, I have been on holiday mode as I have been on one the longest annual leave in my life. Hope you understand the family commitment when you and your kids are on summer holiday (here in Sydney, Dec/Jan/Feb is blazing summer).

 

IPv6, the history and does it really matter to you or anyone?

The simple answer is YES, then why? The single biggest driver behind the development and introduction of IPv6 is  a long prediction of lack of usable IPv4 IP addresses since the explosion of World Wide Web (www) in 1995. The www development goes back to 1991 and then the introduction of grandfather web browser, Mosaic was first introduced in 1993. By year 1995, one third of IPv4 addresses were consumed, by year 2000, half of all IPv4 addresses were use.

As reviewed in previous notes, IPv4 consists of 32 bit address structure and theoretically that should give us 2 to the power of 32 IP addresses, that is 4294967296 IP addresses or roughly, 4.3 billion IP addresses . But not all IP addresses are usable such as the reserved IP addresses for private network use as well as the Class E addresses reserved for development and testing purposes. In other words, only around 2.5 billion IP addresses are true usable addresses. If you just check out our world’s population today ( http://www.worldometers.info/world-population/, China = 1.407 billion and India = 1.2912 billion people,), just looking at top two countries’ population figures, you can feel the IPv4 address shortage on your skin. The trend is that the world’s network has been doubling in size every year for the past 15 years. (https://en.wikipedia.org/wiki/IPv4_address_exhaustion)

With the advancement of new technologies comes the rapid deletion of available IPv4 IP addresses. Anything that’s related to mobile communications and entertainment as well as all other areas seems to be needing more and more IP addresses for everyday use. In the past, it was expected that all the IPv4 addresses would be depleted by 2011 but it is 2016 and we are still using IPv4 address without much thought, all thanks to the counter measures put into place to slow down the IPv4 IP address deletion. e.g.) The fine art of sub-netting, a practical use of DHCP and IP Natting.

 

 Quick note on history of IPv6:

1990 – IETF had predicted that all class B IPv4 IP addresses will be deleted by 1994
1991 Nov – IETF formed  ROAD (ROuting and ADress) Group in Santa Fe, US.
1995 – IPNG (IP Next Generation) Workgroup had written and submitted ‘RFC 1883’, this RFC has become the foundation of current IPv6.
1996 – 6Bone was introduced. 6Bone was a test-bed for IPv6 vulnerabilities connecting 57 countries across 1100 sites.
1999 – IPv6 Forum was launched to standardize the use of IPv6
2006 Jul 06 – 6Bone was decommissioned after 10 years of testing.
Current – Majority of IP products are manufactured with IPv6 capabilities and compatibility. IPv6 is slowly phasing out IPv4 around the world.

Source: https://en.wikipedia.org/wiki/IPv6

 

Quick note on 10 Advantages (Characteristics) of IPv6:
1. Larger IP address space than IPv4, 32 bits based IPv4 vs 128 bits based IPv6
2. Better end-to-end connectivity than IPv4
– peer-to-peer application connections such as games, video conferencing, file sharing and VoIP
– No need to use NAT as the shortage of addresses is thing of IPv4
3. Plug-n-Play feature of IPv6
– plug-and-play auto-configuration, e.g.) DHCPv6
4. Simplified Header structures leading to faster routing
5. Better security features
– use of IPSec (a built-in feature)
6. Improved QoS features
7. Improved Multicast and Anycast abilities
8. Better mobility features
9. Ease of administration over IPv4
10. IPv6 follows the key design principles of IPv4

Source: http://www.ipv6.com/articles/general/Top-10-Features-that-make-IPv6-greater-than-IPv4.htm

In the next section, we will look at some characteristics of IPv6 and then in the final section of IPv6, I will demonstrate IPv6 in a simple lab. Happy blogging, reading and all the best with your learning and career in 2016.

Home networking – Extending Wireless Coverage using an old ADSL/Broadband Modem (The best and cheapest way)

Unfortunately, my home internet router modem was installed on one corner of my house by the Service Provider Technician and it provided only partial wireless network coverage for a number of years. I actually get better signal strength standing outside of my house than sitting in my family room downstairs. But, I really didn’t want to run a thick cable (coaxial) around my house so have been stuck with it for some time. Until…. everyone decided to have a whinge at me, you see whinging actually churn you up and you wanna do something to stop the whinging.

I gave all the excuse in the world to avoid this work at home, but my wife’s whinging finally won in the end and yesterday, I’ ve decided to extend (repeat) my wireless internet connection at home using an old Netgear wireless modem. End-to-end, it took me less than an hour and now my house has an excellent wireless coverage everywhere around the house, the black spots are a history.

To help your understanding of what we are trying to achieve here, look at the pictures below:

Network coverage at my house before placing an extender:

1-1

1-2

Network coverage at my house after placing an extender:

2-1

2-2

First, things you will need to make the most cost effective wireless repeater for your home:

1. ADSL2+/Broadband/Fiber Connected Internet connected Modem with at least 1 free network port. In my case, I have a broadband All-in-one modem, Netgear CG3000-1

2. An old or used wireless modem, this can be anything from Linksys WR54G to the latest WRT1900AC. In my case, I have a used Netgear WNR854T.

3. A 30 – 50 meter long network cable. In my case, I didn’t have one, so I made one using a crimper and RJ45 connectors. If you don’t have the cables or a crimper tool, just buy one from your local electronic store.

Second, this is what you have to do step by step to extend your home wireless network. Please note, we are not after an Enterprise/SMB level business wireless network with a full-on security features here, we are after a cheap, effective and fast home internet coverage.

Step 1: Log into Internet Modem Router’s Admin Web page

5-1

Step 2: Log in with your Admin username and password.

*Note down the following information. The following is an example only, your information will be unique to your home network.

SSID: italchemy001

802.11 mode: 11b/g/n

Bandwidth: 40 Mhz

Wireless channel in use = 1

Security Option = WPA2-PSK [AES]

WPA2-PSK[AES] pre-shared key: !Ta1ch3my!@#

Step 3: Go to the LAN IP settings and change the range of available IP addresses to  reserve for your wireless repeater(s).

5-2

I have reserved 192.168.0.1 – 192.168.0.4. 192.168.0.1 is this voice gateway IP address and 192.168.0.2 will be my wireless repeater(extenders) IP address. Also, 192.168.0.3 – 4 have been reserved, in case I want to add more wireless extenders.

Step 4: Save the new settings and now move to your second device, which is the wireless repeater.

 

*At this point the primary and secondary devices are not connected physically.

Step 5: Turn on the secondary device and connect your PC/laptop to one of the Ethernet port. Now your PC will obtain an IP address allocated by the DHCP services of this modem, by typing in its default IP address, log into the device using the default admin ID and password. My device’s IP was 192.168.1.1, this may vary from manufacturer to another or a device to another.

Step 6: Change the IP address of the secondary modem to a reserved IP of 192.168.0.2 and mask of 255.255.255.0.  Save the configuration and wait until the configuration is saved and become active.

Step 7: Now log back into the second device by typing in the newly assigned IP address of https”//192.168.0.2.  Perform the following tasks:

  • Change your admin password.
  • Turn off the DHCP services, we will use the primary modem router to hand out IP addresses on the same IP range: 192.168.0.XXX.

*It is important that our second modem does not run DHCP services as it will cause problems. The aim of the whole exercise is to keep the network under a single SSID, a single authentication password, different channels on each devices.

5-3

Step 8: Change the SSID and security settings to exactly match your primary router. Also, change the wireless channel to use 6. It is important that you use different channel numbers on Primary and secondary as this will reduce the interference due to overlapping frequencies. So you can use a mixed channels between 1, 6 and 11. You can keep the device name unique as this does not affect the operation.

SSID: italchemy001

802.11 mode: 11n <<< I only want n capable devices to connect to this device

Wireless channel in use = 6

Security Option = WPA2-PSK [AES]

WPA2-PSK[AES] pre-shared key: !Ta1ch3my!@#

5-4

Step 9: Save the settings on your secondary router and reboot.

Step 11: Connect the 30 – 50 meter Ethernet cable from one LAN port on your primary modem router to one LAN port of your secondary modem router.

Step 12: Now both routers are broadcasting the same SSID and allowing computers on the network to access the internet.

TIP: To connect to the secondary modem, you may need to disable and then enable the network settings on your mobile device to connect to newly added repeater.

TIP: To check the network strength of your wireless network, use your Android or iPhone to move around different spots of your house to confirm that there are good signal strength all around your house. I have used an Android app called “WiFi Analyzer”, it is a very good free tool. Alternatively, you can also use your laptop running a WiFi Analyzer program.