GNS3 1.4.2 and IOU VM.ova Installation Tips

Assumption 1: You’ve already have a VMware Workstation or Virtual Box installed and running on your PC/Laptop
Assumption 2: You’ve already downloaded GNS3 1.4.2 and GNS3 VM.ova files from “https://github.com/GNS3/gns3-gui/releases”.
Now Let’s get started:

Step1: Import “GNS3 VM.ova” file on your VMWare Workstation or Virtual Box

Step 1a: Upload IOU L2 and L3 image files on “http://192.168.56.101:8000/upload”, under IOU
Step 1b: Upload CiscoIOUKeygen.py file on “http://192.168.56.101:8000/upload”, under IOU

Step2: Install GNS3 1.4.2
Step 2a: complete basic GNS3 setup following YouTube videos.
One of the videos is as below: https://www.youtube.com/watch?v=1j4VHW-vvR8

Step3: SSH into your IOU VM machine, and go to “/etc” folder and run the following commands under respective folder.
(Video Reference: https://www.youtube.com/watch?v=V0SdjK5tEcA)

Tip: Default IOU VM UID = gns3
Default IOU VM PWD = gns3

Required commands:
echo -ne \\x1\\x0\\x0\\x0 > /etc/hostid
echo -ne \\x1\\x0\\x0\\x0 > /etc/ioukey
echo hostid = 0000001 ; echo hostname = gns3-iouvm ; echo ioukey = 3d9

Step 4: Go to http://192.168.56.101:8000/upload and upload CiscoIOUKeygen.py file

Step 5: Go to /opt/gns3/images/IOU directory and take ownership of the unloaded keygen file

Step 6: use python or python3 command to generate your 16 character long IOU key

root@gns3vm:/opt/gns3/images/IOU# python CiscoIOUKeygen.py
hostid=00000001, hostname=gns3vm, ioukey=25f

Add the following text to ~/.iourc:
[license]
gns3vm = acf51841caabfb0f;

You can disable the phone home feature with something like:
echo ‘127.0.0.127 xml.cisco.com’ >> /etc/hosts

============================================
***Notice that my VM machine works with python command but not python3 command!!!

root@gns3vm:/opt/gns3/images/IOU# chmod +x CiscoIOUKeygen.py

## Notice that python3 command does not work here!!!!
root@gns3vm:/opt/gns3/images/IOU# python3 CiscoIOUKeygen.py
File “CiscoIOUKeygen.py”, line 11
print “hostid=” + hostid +”, hostname=”+ hostname + “, ioukey=” + hex(ioukey)[2:]
^
SyntaxError: invalid syntax
==============================================

Step 7: Using the “gns3vm’ value, create a txt file containg the license information. Save the file as IOURC.txt and point your GNS3 remote server to this txt file.

[license]
gns3vm = acf51841caabfb0f;

Advertisements

CCNA Data Center 640-911 DCICN – Note 18, IPv6 Introduction

This is my first blog in 2016, I have been on holiday mode as I have been on one the longest annual leave in my life. Hope you understand the family commitment when you and your kids are on summer holiday (here in Sydney, Dec/Jan/Feb is blazing summer).

 

IPv6, the history and does it really matter to you or anyone?

The simple answer is YES, then why? The single biggest driver behind the development and introduction of IPv6 is  a long prediction of lack of usable IPv4 IP addresses since the explosion of World Wide Web (www) in 1995. The www development goes back to 1991 and then the introduction of grandfather web browser, Mosaic was first introduced in 1993. By year 1995, one third of IPv4 addresses were consumed, by year 2000, half of all IPv4 addresses were use.

As reviewed in previous notes, IPv4 consists of 32 bit address structure and theoretically that should give us 2 to the power of 32 IP addresses, that is 4294967296 IP addresses or roughly, 4.3 billion IP addresses . But not all IP addresses are usable such as the reserved IP addresses for private network use as well as the Class E addresses reserved for development and testing purposes. In other words, only around 2.5 billion IP addresses are true usable addresses. If you just check out our world’s population today ( http://www.worldometers.info/world-population/, China = 1.407 billion and India = 1.2912 billion people,), just looking at top two countries’ population figures, you can feel the IPv4 address shortage on your skin. The trend is that the world’s network has been doubling in size every year for the past 15 years. (https://en.wikipedia.org/wiki/IPv4_address_exhaustion)

With the advancement of new technologies comes the rapid deletion of available IPv4 IP addresses. Anything that’s related to mobile communications and entertainment as well as all other areas seems to be needing more and more IP addresses for everyday use. In the past, it was expected that all the IPv4 addresses would be depleted by 2011 but it is 2016 and we are still using IPv4 address without much thought, all thanks to the counter measures put into place to slow down the IPv4 IP address deletion. e.g.) The fine art of sub-netting, a practical use of DHCP and IP Natting.

 

 Quick note on history of IPv6:

1990 – IETF had predicted that all class B IPv4 IP addresses will be deleted by 1994
1991 Nov – IETF formed  ROAD (ROuting and ADress) Group in Santa Fe, US.
1995 – IPNG (IP Next Generation) Workgroup had written and submitted ‘RFC 1883’, this RFC has become the foundation of current IPv6.
1996 – 6Bone was introduced. 6Bone was a test-bed for IPv6 vulnerabilities connecting 57 countries across 1100 sites.
1999 – IPv6 Forum was launched to standardize the use of IPv6
2006 Jul 06 – 6Bone was decommissioned after 10 years of testing.
Current – Majority of IP products are manufactured with IPv6 capabilities and compatibility. IPv6 is slowly phasing out IPv4 around the world.

Source: https://en.wikipedia.org/wiki/IPv6

 

Quick note on 10 Advantages (Characteristics) of IPv6:
1. Larger IP address space than IPv4, 32 bits based IPv4 vs 128 bits based IPv6
2. Better end-to-end connectivity than IPv4
– peer-to-peer application connections such as games, video conferencing, file sharing and VoIP
– No need to use NAT as the shortage of addresses is thing of IPv4
3. Plug-n-Play feature of IPv6
– plug-and-play auto-configuration, e.g.) DHCPv6
4. Simplified Header structures leading to faster routing
5. Better security features
– use of IPSec (a built-in feature)
6. Improved QoS features
7. Improved Multicast and Anycast abilities
8. Better mobility features
9. Ease of administration over IPv4
10. IPv6 follows the key design principles of IPv4

Source: http://www.ipv6.com/articles/general/Top-10-Features-that-make-IPv6-greater-than-IPv4.htm

In the next section, we will look at some characteristics of IPv6 and then in the final section of IPv6, I will demonstrate IPv6 in a simple lab. Happy blogging, reading and all the best with your learning and career in 2016.

The planet of Network APEs : Part 2.2 Hybrid Router on a STICK Lab

OK, let’s have some fun with our lab set up! First, let’s configure a quick proof of concept lab, ‘A hybrid router on a stick’:

Router on a stick 1

Preparation for above lab:

1. Install and prepare two virtual machines, mine is called winxp2 and winxp3. I created one and cloned it to make them as two separate VM’s

2. On VM Workstation 11, add two more VM networks. I have added VMnet3 and subscribed winxp2 to it, and added VMnet4 and assigned winxp3 to it. Make sure you disable DHCP services as below screenshots:

Router on a stick 2Router on a stick 3

Router on a stick 4Router on a stick 5

3. Tweak your GNS3 – IOU configuration so, we can add virtual machines and connect them to the topology. This is a very important step, so make sure you get these steps 100%. Go to ‘Edit’ –> ‘Preferences’ and change your settings per screenshots below:

Note: My IOU VM IP is 192.168.52.128, your could be different, so please check.

Router on a stick 8

Router on a stick 6Router on a stick 7

Configure your Local and Remote servers as above.

4. Now Open GNS3 and add the following devices.

a. Add Cisco IOU router and rename to iR1

b. Add Cisco IOU switch and rename to iSW1, connect e0/0 to iR1’s e0/0

c. Drag and drop a cloud, change the name to wxp2, change icon to PC. Configure network interface by adding VMnet3. Now, since we cannot connect the cloud directly to the iSW1’s interface, we need to use a dummy switch to connect these two devices. This is a very important step, so just drop a GNS3 switch and connect wxp2’s interface to SW1’s port 2, then SW1’s port 1 to e0/3 of iSW1.

d. Similarly, for wxp3, repeat the process described as in c using their respective ports.

e. Drag and drop two VPCS (GNS3 built-in) and connect their e0’s to switchports on iSW1. This time, there is no need to use dummy switches.

So at the end of above exercise, you should have a connection similar to the following diagram:

Router on a stick 9

Now the configuration of iR1 and iSW1.

iR1 config:

e0/0 sub-interface configuration:

interface Ethernet0/0
no ip address

no shutdown
!
interface Ethernet0/0.1 <<<This is for VLAN 1 (wxp2 and PC1)
encapsulation dot1Q 1 native
ip address 10.10.10.1 255.255.255.0
!
interface Ethernet0/0.2 <<<This is for VLAN 2 (wxp3 and PC2)
encapsulation dot1Q 2
ip address 10.10.11.1 255.255.255.0

DHCP configuration for VLAN 1 and VLAN 2:

ip dhcp pool ONE
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
ip dhcp pool TWO
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1

iSW1 config:

vlan 2
name CCNA
!
interface Ethernet0/0
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
!
interface Ethernet0/1
duplex auto
!
interface Ethernet0/2
switchport access vlan 2
switchport mode access
duplex auto
!
interface Ethernet0/3
switchport mode access
duplex auto
!
interface Ethernet1/0
switchport access vlan 2
switchport mode access
duplex auto

interface Vlan1
ip address 10.10.10.2 255.255.255.0
!
ip default-gateway 10.10.10.1

——————————————–

Router on a stick 10

5. Now, on PC1 and PC2, run ‘ip dhcp’ command to obtain IP addresses from DHCP server on the router, iR1.

PC1> ip dhcp
DORA IP 10.10.10.3/24 GW 10.10.10.1
PC2> ip dhcp
DORA IP 10.10.11.2/24 GW 10.10.11.1

6. Next, check IP addresses of your Windows Virtual Machines, if everything have been correctly connected and configured, your windows machine also should get the IP addresses from the DHCP server, iR1.

wxp2 IP Address:

C:\Documents and Settings\john>ipconfig

Windows IP Configuration
Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 10.10.10.5
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.10.10.1

wxp3 IP Address:

C:\Documents and Settings\john>ipconfig

Windows IP Configuration
Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 10.10.11.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.10.11.1

7. Now ping IP addresses and verify your PoC lab. You should be able to ping at all IP addresses and also, RDP from one windows machine to another. Have a fun!

Router on a stick 11

Router on a stick 12

The planet of Network APEs : Part 2.1 Vmware workstation, IOU and GNS3 installation and configuration

Following Part 2.0, here is a simple steps to install and configure your Cisco IOU router and switch lab on GNS3.

1 – Install VMware Workstation 11

Download VMware Workstation 11 and install it on your Laptop.

2- Download GNS3 IOU VM.ova appliance

Download GNS3 IOU VM.ova from http://sourceforge.net/projects/gns-3/files/IOU%20VMs/GNS3%20IOU%20VM.ova/download

3 – Install the GNS3 IOU VM

First, import GNS3 IOU VM.

Second, optionally upgrade your GNS3 IOU VM from the OS CLI using ‘pip3 install gns3-server==1.0beta2’ command.

For upgrade to take place, your VM’s network interface must be bridged to your PC’s internet network interface. After the completion of the upgrade, restore VM’s network interface to host-only network.

4 – Configure the VM Network in VMware Workstation 11

Use the following screenshot as your reference point.

Tip: Make the starting IP of DHCP server as 192.168.56.101.

4

5 – Start the GNS3 IOU VM

Log into IOU OS CLI. For OS CLI of GNS3 IOU VM User ID is ‘root’ and password is ‘cisco’

Check the IP address of your IOU server using ‘ifconfig eth0’

Check the server service is running by using ‘ps aux | grep gns3server’

6 – Upload L2 and L3 IOU images

Browse to http://192.168.56.101:8000/upload

Remember your L2 image path for your switch use.

/home/gns3/GNS3/images/i86bi_linux_l2-ipbasek9-ms.may8-2013-team_track

Remember your L3 image path for your router use.

/home/gns3/GNS3/images/i86bi_linux-adventerprisek9-ms.152-4.M1

6

If you don’t have L2 image, download one from the following Google search results:

https://www.google.com.au/?gfe_rd=cr&ei=ZJH7VKeZGsiN8Qft-4CQDA#q=i86bi_linux-adventerprisek9-ms.152-4.M1

If you don’t already have L3 image, download one form the following Google search results:

https://www.google.com.au/?gfe_rd=cr&ei=ZJH7VKeZGsiN8Qft-4CQDA#q=i86bi_linux_l2-ipbasek9-ms.may8-2013-team_track

Or, from here:

https://drive.google.com/folderview?id=0B6VuDLpyDgnHMWhBNXlWQjFIcXM&usp=sharing#list

7 – Create a file with an IOU license key Or download already made IOU license key

Option 1: If you already have a genuine licence key. Create a text file called ‘iourc.txt’ and cut and past the following contents, save.

[license]

gns3-iouvm = xxxxxxxxxxxxxxxx;

Option 2: If you don’t have a key, then your next option is to find a key on the net.

Download it from http://forum.gns3.net/topic9032.html

Now create a folder under C:\ called IOURC and save the file under the newly created folder.

7

8 – Putting it all together

Launch GNS3 and go to Preferences à Server à Remote Servers and add your VM IP address (192.168.56.101) as a Remote Server. Then click ‘Apply’ and ‘Save’.

8

9 – Add the IOU license key file

On the same Preferences menu, go to ‘IOS on Unix’. Clicke to iourc.txt file path under ‘General Settings’

9

10 – Add L2 and L3 IOU devices

Add L2 and L3 IOU devices on GNS3. Each time you add a device, click ‘Apply’ and ‘OK’.

10a

10b

11 – Testing your IOU image

Configure a simple lab and run your testing. Now you are ready to go.

11

Note: If you are having issues opening up the upload web page for IOU images, please use WinSCP and drop both L2 and L3 images into “/home/gns3/GNS3/images”:

Protocol: SCP

Port: 22

UID: root

PWD: cisco

winscp

The planet of Network APEs : Part 2.0 Welcome back GNS3 and thank you Cisco for leaking out IOU!

Welcome back Network Apes! It has been extremely busy with work, study and family. I was having trouble finding time to write something useful for anyone who is interested in or studying Cisco Technologies. Even to get to the point of writing this post, I had to spend about 10 days familiarizing myself with the idea of using GNS3 GUI as an application, this was due to the painful memories of sitting in front of my PC, trying to fix some silly old GNS3 bugs and also my preference of Dynamips over old GNS3. At one stage, it did not make sense to me to use very very buggy old GNS3 over Dynamips, it was not worth my time and pain to work with old GNS3 and its million bugs.

As I have discussed in earlier posts, I have come across Cisco Web-IOU and its support for almost full set of Cisco IOS commands in a virtual environment, Wow… Cisco IOS on Linux virtual server running (exactly emulating) IOS 15.x and also, providing close to real L2/L3 switch experience (not the crappy NM-16ESW module as in Dynamips/old GNS3)!!! You can see that the new GNS3 and IOU have a serious potential to help networking students and Engineers to use their time and money for better things.

Initially, testing out the IOU, I used the Web-IOU and it is pretty impressive in its own ways but soon ran into limitations. How do I connect some virtual machines running on the same host machine to the virtualized IOU network? Thanks to many others who also labbed, documented and shared their guides on how to do things, there were lots and lots of documents, some very useful but most of them rubbish as I have been trying to do this on a Windows 64bit machine! Yeah, go ahead and laugh at me and the 95% of the PC users, I was trying to do this on a windows machine, specifically a laptop, you can find my PC specs and the items you will need to set you up for hundreds of free and very interesting Cisco/Microsoft/Linux labbing.

Guess what I have discovered after hours of Google search? “Your IOU will have to be integrated with the newer version of GNS3!” On initial discovery I thought “WTF, GNS3? Oh No, not again!!!”. I was totally disappointed with the truth and challenge I was facing. Yes it is still very useful and free of charge, but still extremely temperamental like a red-haired, nose pieced and rocking rolling gf on redbull on Vodka, it has totally eaten up my whole weekend with many hours of pain, I even took this problem to my sleep so I can solve the problem in my dreams. Only after 3 days of struggle I was able to set up something useful working with both IOU and new GNS3. Please see the picture below to understand what I have been trying to do in last 3 days. A very simple bus topology lab, which will serve any Networking student and Engineers the basic foundation you need to do many labs in a single PC or laptop. I will close this post with just an introduction to what was required to set this lab up and then share with everyone the step-by-step configurations in the trailing posts.

GNS3 IOU 002

The topology is simple and expandable, the connection is as below:

PC1—SW1—R1——R2—SW2—PC2

  • PC1 is a Windows 8 VMware workstation VM.
  • PC2 is a Windows 7 VMware Workstation VM.
  • SW1  and SW1 are IOU L2 switch.
  • R1 and R2 are IOU routers.

Lab hardware & software used:

Hardware:

  • ASUS K53SD with i7 2670QM CPU, 128GB SSD, 8GB DDR3 memory

Software:

The planet of Network APEs : Part 1.3 – Studying Cisco certs, nothing is for free? Really?

As many of the networking students preparing Cisco exams or just trying to practice and consolidate their knowledge or attempting to validate some proof of concept using the most cost and time effective way possible, “the culprit” preventing students to dive deep into Cisco Technologies and freely explore and learn always have been the initial cost of ownership of such lab, setting up a decent lab and use it to our full advantage is our ultimate goal here, but at what budget? It is so true that not everyone can afford the actual physical equipment lab to practice your certification labs. Yes, we all agree on the idea that ‘the best way to learn Cisco Technologies is using all hardware based lab’. But who can afford $4000 for a single switch and $2500 for a barebones router where you have to purchase extra modules separate to make your router to do what you want to do. And then you need a number of these equipment when you get beyond CCNA level. Even if you are one of more fortunate students, who have been able to break into a job, where your work provides all equipment for your work/personal use, you’re not free to do anything you want to do with these equipment as in most of the time, these equipment are shared resources between a group of Engineers. Cisco themselves have seen this limitation of economics and they have developed an internal use only application based on Solaris Linux simulator called Cisco IOU. Sheeeesh! we are not supposed to mention the word IOU in public but it could well be an abbreviation for “I Owe You” as in I owe you something. Before Cisco IOU, there was Dynamips (GNS3 is a GUI Dynmaips, nothing more) and Cisco Packet Tracer. In the last 10 to 15 years, we have seen these readily free applications which either try to emulate or simulate the real Cisco routers, switches and servers in some way or another.

In this post, I would like to make a brief introduction of each emulator(s) or simulator(s) then make a quick comparison, and then demonstrate, how these tools (or applications) can help you to learn Cisco Technologies and the relevant Certifications. To give you some background on these applications’ potentials as free tool(s) to learn Cisco exams, I also have been a user and an advocate of free emulation/simulation applications, in few years back I have studied and completed all components of CCNP ROUTE exam preparation labs using a single PC and Dynamips as my preferred Cisco router emulator. Although, the SWITCH exam labs were completed using actual physical hardware (2 x 3550 and 2 x 2950 switches). Going few years back working for Cisco as an internal IP Support (contractor), I heard many good things about Cisco IOU for years and now, I have decided to test it out in the form of web version of Cisco IOU, I can see even more potentials where the IOU can be used in preparation of CCNP SWITCH and TSHOOT exam. The reason behind moving away from Dynamips as my preferred tool is that Dynamips only support end of support Cisco Router images (IOSs) and platforms, also I’ve always had challenges trying to emulate a meaningful Cisco Switching using L2 Ethernet module (NM-16ESW), these were OK but never cut the line.

As I have mentioned in the opening sentence, there are two types of readily free applications, Simulator and Emulator. First, let’s define the terms and understand the difference, after that, I will tabulate different tools and make a quick introductory comparison. In the second half of this post, I will add an example lab to further help your understanding.

 A: Difference between a Simulator and an Emulator

A simulator is a system that behaves similar to something else, but is implemented in an entirely different way. It provides the basic behaviour of a system but may not necessarily abide by all of the rules of the system being simulated. It is there to give you an idea about how something works. E.g.) a flight simulator

An emulation is a system that behaves exactly like something else, and abides by all of the rules of the system being emulated. It is effectively a complete replication of another system, right down to being binary compatible with the emulated system’s inputs and outputs, but operating in a different environment to the environment of the original emulated system. The rules are fixed, and cannot be changed or the system

Application Emulator/ Simulator Open Source/ Proprietary Pros & Cons
Cisco Packet Tracer Simulator Proprietary Pros:

Cheap

Very easy to use (suits beginners)

Good for learning basic concept

Readily available on torrent sites or free file share sites (download and use at your own risk)

OK study tool for Cisco Certification

Cons:

Nothing close to real Cisco IOS

Nothing close to real Cisco hardware

Dynamips Emulator Open Source (still requires extracted Cisco IOS image(s)) Pros:

Free

Fairly easy to use (suits Intermediate users)

Good for learning basic concept

Support for older router platforms

Very versatile

Easy integration with Virtual Machines

Easy integration with other hardware

Less bugs than GNS3’s

Support for both Windows OS and Linux OS

Very good study/work tool for Cisco Certification

Cons:

You’ll have to find your own IOS copies

Only support older IOS routers (with exception of 7200 router)

Limited Switching capabilities

Support through open source forums only

GNS3 Emulator Open Source (still requires extracted Cisco IOS image(s)) Pros:

Free

Very easy to use (suits beginners)

Good for learning basic concept

Support for older router platforms

Very versatile

Easy integration with Virtual Machines

Easy integration with other hardware

Support for both Windows OS and Linux OS

Very good study/work tool for Cisco Certification

Cons:

You’ll have to find your own IOS copies

Only support older IOS routers (with exception of 7200 router)

Limited Switching capabilities

Lots of bugs

Lots of performance issues

Support through open source forums only

Cisco IOU Simulator Proprietary Pros:

Fairly easy to use (suits Intermediate users)

Support for later or latest IOS’s

Excellent L2/L3 switch simulation

Can run on most WIN/Linux Virtual Applications

Readily available on torrent sites or free file share sites (download and use at your own risk)

Excellent study/work tool for Cisco Certification

Cons:

Proprietary

No support from Cisco, find your own copy and use at your own risk (but don’t tell Cisco that you found a copy on the web)

Part 2: Example Lab: Network Connectivity

Equipment Required

  • Cisco router (x1)
  • Switch that supports voice VLANs (x1)
  • PC for testing (x1)
  • Cisco IP Phone (optional, but useful if switch supports Power over Ethernet [PoE]) (x1)

Learning Objectives

  • Perform basic router and switch configuration
  • Configure VLANs to support data, voice, and network management traffic
  • Configure VLAN trunking between a router and a switch using subinterfaces
  • Configure router-based DHCP pools for voice and data devices

Scenario

ABC company would like to establish its new data network with the expectation of using VoIP in the future.

The device name, IP Addressing and VLAN schemes are as below:

Host Name VLAN Name VLAN # IP Address DHCP Pool Default Router
R1 Management 100 10.100.0.1/24
Data 202 10.202.0.1/24 10.202.0.0/24 10.202.0.1
Voice 102 10.102.0.1/24 10.102.0.0/24 10.102.0.1
SW1 100 10.100.0.2/24 10.100.0.1
PC1 202 Auto provisioned Any from 10.202.0.0/24 range

The network topology:

IOU topology1

==============================================================================================

Type 1: Hardware-based lab

Task 1-1: Clear prior configuration on both router and switch. Make sure you save any old configurations before performing this task.

R1#write erase

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

SW#write erase

Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]

Task 1-2: Cable R1, SW1 and PC1 as shown in topology

Task 2-1: Basic router setup

R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

router#conf t

router(config)#hostname R1

R1(config)#no ip domain lookup

R1(config)#enable secret lab

R1(config)#line con 0

R1(config-line)#logging synchronous

R1(config-line)#exec-timeout 180 0

R1(config-line)#password cisco

R1(config-line)#login

R1(config-line)#line vty 0 4

R1(config-line)#password cisco

R1(config-line)#login

R1(config-line)#exit

<<< Change router name to R1

<<< Do not resolve IP via DNS

<<< Conf t password = lab

<<<

<<< New line when system messages come pop

<<< 3 hours idle before automatic log-off

<<< Console password = cisco

<<<

<<< Telnet lines 0 4 (optionally use line 0 15)

<<< Telnet password = cisco

<<<

<<<

Task 2-2: Basic Switch setup

switch#conf t

SW(config)#hostname SW1

SW1(config)#vlan 202

SW1(config-vlan)#name DATA

SW1(config-vlan)#vlan 100

SW1(config-vlan)#name MANAGEMENT

SW1(config-vlan)#vlan 102

SW1(config-vlan)#name VOICE

<<< Change switch name to SW1

<<< Define VLAN ID

<<< VLAN 202 name is DATA

<<< —as explained above—

<<<

<<<

<<<

Task 2-3: Trunk port configuration on SW1

SW1(config)#int fastethernet 0/1

SW1(config-if)# switchport trunk encapsulation dot1q

SW1(config-if)#switchport mode trunk

<<< want to chang fa0/1 only

<<< enable this port as 802.1Q

<<< This port use is for a trunk

Task 2-4: Access port configuration on SW1

SW1(config)#int fastethernet 0/2

SW1(config-if)# switchport mode access

SW1(config-if)#switchport access vlan 202

SW1(config-if)#switchport voice vlan 102

SW1(config-if)#spanning-tree portfast

<<< want to change fa0/2 only

<<< This port is for an end device

<<< Data vlan is 202

<<< Voice vlan is 102

<<< Remove STP wait time

Task 2-5: Configure SW1 management interface

SW1(config)#int vlan 100

SW1(config-if)# ip add 10.100.0.2 255.255.255.0

SW1(config-if)#exit

SW1(config)#ip default-gateway 10.100.0.1

<<< want to change int vlan 100

<<< Interface IP address

<<<

<<< out through 10.100.0.1

Task 2-6: Configure R1 subinterfaces

R1#conf t

R1(config)#int fastethernet 0/0.100

R1(config-if)#description Management VLAN

R1(config-if)#encapsulation dot1Q 100 native

R1(config-if)#ip address 10.100.0.1 255.255.255.0

R1(config-if)#interface fastethernet /0.102

R1(config-if)#description Voice VLAN

R1(config-if)#encapsulation dot1Q 102

R1(config-if)#ip address 10.102.0.1 255.255.255.0

R1(config-if)#interface fastethernet /0.202

R1(config-if)#description Data VLAN

R1(config-if)#encapsulation dot1Q 202

R1(config-if)#ip address 10.202.0.1 255.255.255.0

R1(config-if)#int fastehernet 0/0

R1(config-if)#no shut

<<<

<<<

<<<

<<< Talk through vlan 100 natively

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

<<<

Task 2-7: Verify your configuration on SW1

SW1#show vlan

VLAN Name                             Status    Ports

—- ——————————– ——— ——————————-

1    default                          active    fa0/3, fa0/4, (…omitted for brevity)

100  MANAGEMENT                       active

102  VOICE                            active    fa0/2

202  DATA                             active    fa0/2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

SW1#how interfaces switchport

 

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 100 (MANAGEMENT)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

<output omitted>

Name: Fa0/2

Switchport: Enabled

Administrative Mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: negotiate

Operational Trunking Encapsulation: native

Negotiation of Trunking: Off

Access Mode VLAN: 202 (DATA)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: 102 (VOICE)

<output omitted>

Task 2-8: Verify your configuration on R1

R1#show ip interface brief

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                unassigned      YES unset  up                    up

Ethernet0/0.100            10.100.0.1      YES manual up                    up

Ethernet0/0.102            10.102.0.1      YES manual up                    up

Ethernet0/0.202            10.202.0.1      YES manual up                    up

Ethernet0/1                unassigned      YES unset  administratively down down

Task 2-9: DHCP Pool configuration on R1

R1#conf t

For any PC or Servers:

R1(config)#ip dhcp excluded-address 10.202.0.1 10.202.0.10

R1(config)#ip dhcp pool DATA

R1(dhcp-config)#default-router 10.202.0.1

R1(dhcp-config)#network 10.202.0.0 255.255.255.0

R1(dhcp-config)#exit

For phones:

R1(config)#ip dhcp excluded-address 10.102.0.1 10.102.0.10

R1(config)#ip dhcp pool VOICE

R1(dhcp-config)#default-router 10.102.0.1

R1(dhcp-config)#network 10.102.0.0 255.255.255.0

R1(dhcp-config)#exit

=============================================================================================

Type 2: Cisco IOU based lab

Well, where do I start?

OK, go to google and do a search with search handle, “Cisco IOU v22” or “Cisco IOU v22 ovf”, try to find this ovf file and add it as a virtual machine on any of your preferred Desktop virtual machine programs (or click here).

In my case, I have installed Cisco IOU v22 on my laptop in VMware Workstation 10. Apologies, but I won’t be able to provide you a copy of the IOU or the VMware Workstation 10, you will have to find it or purchase one and install them on your PC/laptop. Since you are reading this post, I assume that you are familiar with the basic installation/deployment of virtual machines on VMware Workstation.

Task 3-1: Create a folder on IOU Web

3-1

Task 3-2: Create a lab

3-2a

Copy and paste the following Netamp information in “NetMAP” section.

1:0/0 10:0/1

10:0/2 100:0/0

1 represents Router 1 (R1), 10 represents Switch 1 (SW1) and 100 represents PC1.

So, Ethernet 0/0 of R1 connects to Ethernet 0/1 port of SW1. And, SW1’s 0/2 port connects to PC1 Ethernet port.

Devices configuration is as below:

3-2b

Now, exit out and start the router and switch. The topology from IOU looks like this:

3-2c

Task 3-3: Start and configure R1 and SW1 per our lab requirement (refer back to ‘Type 1: Cisco hardware based lab’ configurations)

3-3

Now console into R1 and SW1, start configuring the router and switch. Us the same configuration steps given in ‘Type 1: Hardware-based lab’. The configuration is exactly same but watch out for switchport differences if you have assigned different ports for the trunk and access ports. Also, the ethernet ports comes up as Ethernet ports, not FastEthernet ports, your fa0/1 will be e0/1 instead.

3-3a

Task 3-4: Check the interfaces on R1 and ping SW1 vlan interface IP to check the connection:

R1#show ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                unassigned      YES NVRAM  up                    up

Ethernet0/0.100            10.100.0.1      YES NVRAM  up                    up

Ethernet0/0.102            10.102.0.1      YES NVRAM  up                    up

Ethernet0/0.202            10.202.0.1      YES NVRAM  up                    up

Ethernet0/1                unassigned      YES NVRAM  administratively down down

R1#ping 10.100.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.100.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Task 3-5: Check the interfaces on SW1 and ping the virtual interface e0/0.100 on R1 interface IP to check the connection:

SW1#show ip int brief

Interface              IP-Address      OK? Method Status                Protocol

Ethernet0/0            unassigned      YES unset  up                    up

Ethernet0/1            unassigned      YES unset  up                    up

Ethernet0/2            unassigned      YES unset  up                    up

Ethernet0/3            unassigned      YES unset  up                    up

Ethernet1/0            unassigned      YES unset  up                    up

Ethernet1/1            unassigned      YES unset  up                    up

Ethernet1/2            unassigned      YES unset  up                    up

Ethernet1/3            unassigned      YES unset  up                    up

Vlan100                10.100.0.2      YES NVRAM  up                    up

SW1#show vlan

VLAN Name                             Status    Ports

—- ——————————– ——— ——————————-

1    default                          active    Et0/0, Et0/3, Et1/0, Et1/1

Et1/2, Et1/3

100  MANAGEMENT                       active

102  VOICE                            active    Et0/2

202  DATA                             active    Et0/2

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

SW1#ping 10.100.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.100.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

As demonstrated in this simple lab, a basic network connectivity lab is completed using Cisco IOU and we have validated the connection between two devices. The most of configurations we have configured using hardware (Cisco 2811 router and Cisco 3550 switch) can be emulated in Cisco IOU, and the configuration task was completed on a single PC/laptop. Hope this post has intrigued your interest and have given you some insight and potential of such  tools for our learning and proof of concept labs. For more advanced topic on how to set up a complete CCNA, CCNP and CCIE labs, please dig deeper for more documents in Google.

The planet of Network APEs : Part 1.1 – To be Certified OR not to be Certified, that’s the question

There are thousands, perhaps millions of free and paid Cisco Networking training materials in this world, these are offered in the form of free materials on the net, formal classroom training, informal on-line training, training videos, books, self-built and taught labs and most importantly and by far the best training is, on the job training.

Whether you are technical or non-technical or trying to become technical, you belong to one of the two groups of people from Cisco’s perspective. That is ‘Cisco Certified’ or ‘Not Cisco Certified’. Well, what does this mean to anyone really? I think it could have different meaning to different people. But, here is my version of Cisco Certified. First, if you are non-technical and not certified, Cisco networking and its certifications mean jack sh**, a full stop (If you belong to this group, you are excused for stop reading this post here). Second, if you are non-technical and certified, you were probably drunk or on crack while you were studying and while taking the certification exam. Third, if you are technical and non-certified, you are making a living as a technician but when it comes to study, you are a lazy ar**. If you are technical and certified, you are either in good demand or will soon be in great demand in the job market. Well, I try to be an optimistic and positive person here, so don’t try to argue with me if you are technical and certified, but yet, unable to find any work for many months/years. If you are in this category, go and have look at yourself in the mirror, look back on what you have been doing wrong to secure your next job and after that, spend some time reworking your strategies to score that illusive next dream job, but be focused and always stay +++POSITIVE+++. Here, take this! Bang! Bang! “++++++++++”. You now have just taken my 10 positive energy and you are ten times more positive about your future. Just like happiness, more positive energy you share, happier our world becomes.

OK, now you are asking what’s the true meaning of this post’s title “The planet of Network APEs”? You might be thinking “WTF?” Ah, that just means if you are interested in studying Cisco technologies, you should be ready to become a Network monkey, a monkey belongs to Ape family group. You see, we sometimes call car Mechanics, “The grease monkies”, these people love their profession and they love their cars. More widely used term for Network Engineers who love to get Cisco Certified is “Certification Junkies”, but “Network APEs” or “Network monkies” will do me good here as these people will go Ape sh** when it comes to studying and working with Cisco Networking technologies, because they love what they do and you will also become one of them, there are thousands of APEs managing your network in this world, so you can use your iPhone/ iPad and Samsung Galaxies on social media to talk to your friends and also reading posts like this. Ah, actually, I am only joking about this post’s title, let’s cut out this BS and explain why the post’s title is “The planet of Network APEs”, the abbreviation for ‘APE’ stands for ‘Associate’, ‘Professional’ and ‘Expert’, these are the three levels of the most common Cisco Certification paths. I am using three combined word abbreviation because I would like my posts to be read, understood and help others at all technical levels (including myself).

I would like to use my posts as information sharing grounds for people who are studying Cisco Networking and also, use it as my working knowledge pad for future reference. Now, if you are reading this line in this post, I am assuming that you are either studying now or interested in studying Cisco Networking in the future. If you have not had a chance to sit down and think about 4 w’s and 1 h, perhaps you should ask these questions now to know the exact intentions and intended outcomes of your study:

  1. Why do we want to study routing and switching?
  2. What do we study in Cisco routing and switching?
  3. When do we study Cisco routing and switching?
  4. Where do we study Cisco routing and switching?
  5. How do we study Cisco routing and switching to get the most out of my study?

Everyone’s answers will be different and, the path and expected outcome also may vary. The differences are through many factors and sometimes, it depends on your luck (sure, call me a superstitous bastard, but this is very true and you cannot bend it 🙂 ). In the next part, I would like to share my answers to these questions, then I will start sharing Cisco Routing and Switching notes in series. Happy reading and thank you for reading my post!